Author Topic: Network Rendering Problem : slave computer lags behind main by a lot  (Read 11124 times)

0 Members and 1 Guest are viewing this topic.

Offline Brandon Davis

  • Jr. Member
  • **
  • Posts: 77
    • KeyShot
Re: Network Rendering Problem : slave computer lags behind main by a lot
« Reply #15 on: January 02, 2015, 09:15:39 am »
Hope you guys had a great new year.
Still haven't heard from any of the admin or moderators here though about where I can upload the file.
I'd like to share it with you and have it tested yourself. Otherwise, you can mimic my scene by just taking a 3 million polymesh and import it into keyshot and apply a random texture on it, and test network rendering with my same setup, and you might get the same slow results.

The reason why you are seeing slower times when using network rendering is because the job needs to be archived and sent across the network. For renders that take < 3 minutes on your local machine, might not be faster when rendering across the network depending on scene size and machine specs.

As a test case, could you set the resolution of your rendering to be 1920 x 1080 - jpeg, with quality set to max samples 128? Render local vs network. What are your results?

As simple test I ran:
Scene: 2.42 GB
Res: 1920 x 1080, jpeg
Local: 8 cores, 8 minutes 24 seconds
Network: 26 cores, 4 minutes 38 seconds

Offline Knarlsbest

  • Newbie
  • *
  • Posts: 13
Re: Network Rendering Problem : slave computer lags behind main by a lot
« Reply #16 on: January 03, 2015, 04:58:48 am »
Thanks. I don't understand why the limitation, when in fact that's what network rendering is for. To be able to render big files that you would otherwise take too long on a single computer, not to render small 3 min renders more efficiently.

Anyways, here are my results,
scenefile - 6GB
main cpu standalone- 6 min. render time 8 cores
main cpu and second cpu over the network- 9 min 35 sec total 16 cores
« Last Edit: January 03, 2015, 05:53:01 am by Knarlsbest »

Offline Knarlsbest

  • Newbie
  • *
  • Posts: 13
Re: Network Rendering Problem : slave computer lags behind main by a lot
« Reply #17 on: January 05, 2015, 08:29:30 pm »
Hi,
Any updates?
Thanks

Offline Brandon Davis

  • Jr. Member
  • **
  • Posts: 77
    • KeyShot
Re: Network Rendering Problem : slave computer lags behind main by a lot
« Reply #18 on: January 06, 2015, 06:12:47 am »
Thanks. I don't understand why the limitation, when in fact that's what network rendering is for. To be able to render big files that you would otherwise take too long on a single computer, not to render small 3 min renders more efficiently.

Network rendering is designed to do the exact opposite, as I stated in a previous post. A general rule of thumb when to use network rendering is to render scenes that take longer than 3-5 minutes when rendering locally within KeyShot, or to offload the work to different machines. Of course there are other factors that play into this rule, such as scene complexity, file size, network speed, and machine specs that are in use for network rendering.

Anyways, here are my results,
scenefile - 6GB
main cpu standalone- 6 min. render time 8 cores
main cpu and second cpu over the network- 9 min 35 sec total 16 cores
Thank you for these results.

My assumption is that the network speed is the bottleneck here. Can you send an email to support @ luxion.com along with your serial code? They will be able to setup a web meeting so we are able to further investigate.

// Brandon