Author Topic: Help Needed: Lighting a scene with emissive  (Read 7155 times)

0 Members and 1 Guest are viewing this topic.

Offline cadkeys_1

  • Newbie
  • *
  • Posts: 5
Help Needed: Lighting a scene with emissive
« on: May 20, 2014, 12:02:52 am »
Hi,

I'm new to KeyShot and am having some weird issues with it when attempting to use emissive materials to give a spot light effect.

My 'lights' are essentially just flat cylinders sitting through the roof material which I'm making emit light.  They work mostly but some have those awful light flares around them which I can't get rid of.

Also the back wall is grubby and the TV on the wall is casting a shadow upwards.

Clearly I'm lacking the required skill to debug this myself and want to throw this out there.

Incidentally I tried using Point Light and Area Light and they make the scene look like a nuclear bomb just went off, everything goes blinding white, even if I set the Wattage to 1, or 0.1, 0.001 !

I'm using IronCAD to do the modelling and have the proper plugin for KS4 for that program installed.

I'm literally looking to put spotlights which cast light but have a soft/diffuse effect rather than a sharp cast like a flashlight.

I really appreciate any help on this.

Attachment of an example shot.




Offline TpwUK

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 2910
Re: Help Needed: Lighting a scene with emissive
« Reply #1 on: May 20, 2014, 12:27:35 am »
Hello CadKeys,

Firstly check your model scale, getting massive overburn from regular lights is usually a sign of the model having no defined units scale.
You can also set the units scale in KS using the Edit/Set Scene Units

Once your model has been scaled, and if you know what light bulb it is you want to use, find its IES file and you can use that in KS3 upwards

Martin

Offline cadkeys_1

  • Newbie
  • *
  • Posts: 5
Re: Help Needed: Lighting a scene with emissive
« Reply #2 on: May 20, 2014, 01:03:12 am »
That's great thanks.

I was working in cm in IronCAD and this is an exact scale drawing there.  It's quite possible it's lost the units in the transfer to KeyShot.

There is a distributed plugin for IronCAD to work well with KeyShot but I'm not really clear what it does.  You'd think passing the unit scale across with the model would be a fundamental requirement of a plugin.

Regardless, I'll have a look at the model scale.

Is there anything I can do about the emissive light flares and the grubby effect on the back wall?

I was going to up the samples of the entire model and see if that does anything.

Offline TpwUK

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 2910
Re: Help Needed: Lighting a scene with emissive
« Reply #3 on: May 20, 2014, 03:25:58 am »
Quote
Is there anything I can do about the emissive light flares and the grubby effect on the back wall?

Not sure what is causing those flares, could be just the camera/light angle combining to create hotspots. The grubby effect could be not enough bounces or samples. Dont forget your emitter has a setting for samples on its own so that could save the render time a little. Also you could give Global Illumination a try too. You will also find that once you start adding materials and textures and how they react with light that those 'grubby' patches can be reduced

Martin

Offline cadkeys_1

  • Newbie
  • *
  • Posts: 5
Re: Help Needed: Lighting a scene with emissive
« Reply #4 on: May 20, 2014, 03:56:14 am »
Thanks Martin.

I tried some of this and I think I may have worked out what was causing the hot spots.  The cylinders I was using as a light source were hanging down about 20mm and I believe it was the edges of the cylinders that was emitting light as well that was causing this.  I reduced the drop to about 2mm and it is significantly imrproved.

I checked the models units and it was set to 'cm' as the original model so I'm not sure what is causing the over burn using the other lights.

If I use 'Area Light Diffuse' I have to reduce the Lumen to 0.5 to get it to the point where the lights are bright and casting a nice effect on the scene without over burning.  1 Watt causes massive overburn.  Really not sure what the issue is here.

Is there a way to measure the model KeyShot to see if my measurements have come across intact?   You wouldnt expect this behaviour really.  This models is 8m x 3m x 3.6m so a tiny little 100W light source should not really be having the effect that it is.  A 0.5 Lumen light source is so dim in reality you'd barely notice it.



On the grubby effect, I found that sinking the emitting object, upping the indirect bounces from 1 to 2, increasing the entire objects samples to 20 and adding a bloom effect went a long way to reducing the issue.  And as you say when I actually start applying material to the various surfaces, and labels, I expect the majority of this effect will be concealed, invisible.

Thanks for you help.

Offline TpwUK

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 2910
Re: Help Needed: Lighting a scene with emissive
« Reply #5 on: May 20, 2014, 05:28:25 am »
cool ... glad things are working out

If you go to the menu bar at the top of the screen, File, Edit etc - Select edit, then select set scene units, you can then force it to be whatever units you prefer :)

Martin