Author Topic: Label transparency not working  (Read 7025 times)

0 Members and 1 Guest are viewing this topic.

Offline Pepster3D

  • Jr. Member
  • **
  • Posts: 98
    • Pep Creative
Label transparency not working
« on: March 14, 2014, 06:47:02 am »
Hi,
 I wanted to put a photo of a person on a plane and have the background transparent.  I've tried a bunch of ways of doing a label with a transparent background, and it's not working.  I keep getting a white background.  I tried TIFF with alpha, and PNGs with transparency at 8 and 16 bit.  I've attached my test file.  I'm using Keyshot 4.1.35.  Thanks.

 :'( :'( :'(

Offline Robb63

  • Hero Member
  • *****
  • Posts: 584
Re: Label transparency not working
« Reply #1 on: March 14, 2014, 08:10:37 am »
It's because your material "Type" is still set to "Diffuse". Try switching the material to a transparent type of material

thomasteger

  • Guest
Re: Label transparency not working
« Reply #2 on: March 14, 2014, 12:16:51 pm »
I will take a look. And why are you still using 4.1? 4.3.18 is the latest.

thomasteger

  • Guest
Re: Label transparency not working
« Reply #3 on: March 14, 2014, 12:27:24 pm »
Just like Robb63 said. Use Glass, and set the IOR to 1.0. Or apply an advanced material, apply the label as a texture, check Use Diffuse Map Alpha under the Advanced Property options. Turn off repeat for the texture, and scale it to your liking. You can use the position tool to get in the right place.

Hope this helps.

Offline Pepster3D

  • Jr. Member
  • **
  • Posts: 98
    • Pep Creative
Re: Label transparency not working
« Reply #4 on: March 14, 2014, 12:28:08 pm »
@Thomas, you know how IT departments are.  I am still waiting for my update to be installed by someone with Admin rights. ::)

Offline Pepster3D

  • Jr. Member
  • **
  • Posts: 98
    • Pep Creative
Re: Label transparency not working
« Reply #5 on: March 14, 2014, 12:28:50 pm »
Thanks Robb63 and Thomas, I'll give that a try!

Offline SaltPD

  • Newbie
  • *
  • Posts: 4
Re: Label transparency not working
« Reply #6 on: July 25, 2016, 01:03:37 am »
I am having this problem too. I've done this before successfully but I am no longer able to do it. I've tried tga and png with transparency. I am using Keyshot 5.3.6. Label is attached. I must be missing something obvious. Any help would be appreciated.

Offline NormanHadley

  • Full Member
  • ***
  • Posts: 239
    • NCH Design
Re: Label transparency not working
« Reply #7 on: July 25, 2016, 01:46:00 am »
Hi SaltPD. Is this the kind of effect you're after? (I've just put your label on a default cylinder)

Offline SaltPD

  • Newbie
  • *
  • Posts: 4
Re: Label transparency not working
« Reply #8 on: July 25, 2016, 09:05:49 pm »
Thanks Norman,
Almost. I want the white in the png to be white and the background to be transparent so that the red textured surface is visible. I am using a brushed red anodised material too (Type: metal). I can't open your ksp file as it appears to be created in a newer version of Keyshot than mine. (5.3.6). Perhaps you could supply your material file?

Offline NormanHadley

  • Full Member
  • ***
  • Posts: 239
    • NCH Design
Re: Label transparency not working
« Reply #9 on: July 25, 2016, 11:20:29 pm »
Ah, maybe this is more like it? Yes, I'm using 6.2.105. I found I could only get what you wanted by editing your PNG file as it was behaving as if the background was red. I also attach my version of it.

Offline SaltPD

  • Newbie
  • *
  • Posts: 4
Re: Label transparency not working
« Reply #10 on: July 25, 2016, 11:36:03 pm »
That's the look Norman. I tried your png file and it works. I've tried outputting a number of files types from Corel Photo Paint X3 (old) and Gimp without success. The Corel:Keyshot combo used to work fine and I haven't updated Corel....hmmm.

Thanks for all your help.

Offline NormanHadley

  • Full Member
  • ***
  • Posts: 239
    • NCH Design
Re: Label transparency not working
« Reply #11 on: July 25, 2016, 11:39:52 pm »
Great. The funniest part is the sophisticated, high-end graphics package I used to tweak the png.......Microsoft  Word 2010.  ;)

Offline SaltPD

  • Newbie
  • *
  • Posts: 4
Re: Label transparency not working
« Reply #12 on: July 25, 2016, 11:41:41 pm »
Awesome!