Author Topic: Solidworks imports of tubes can't be textured properly  (Read 8011 times)

0 Members and 1 Guest are viewing this topic.

Offline iahdesign

  • Newbie
  • *
  • Posts: 6
Solidworks imports of tubes can't be textured properly
« on: December 19, 2013, 02:55:34 am »
When creating a sweep extrude of a tube with many bends imported with the SW plugin into Keyshot it's impossible to texture it properly.

Here is an example of a sweep extrude with several bends, imported into Keyshot 4.3 (using the latest SW plugin) with the standard Aluminum Hexagonal Mesh applied to it with UV Coordinates as type:

This is not the result I am looking for; and it's impossible to get the texture right with a different type due to the ammount of bends.

I also tried the beta import of a SW part file:

Results is even worse.

Finally I also tried exporting the file to .IGS in SW and then imported it into Keyshot:

This result is much better (still some little mistakes on a line of the section; but hardly visible)

I am satisfied with the last result, but I have to export all my files as .IGS in order to make this work; is it possible to add an option to the SW plugin to convert the files to .IGS before loading it into Keyshot? Or maybe some sort of conversion on the files to create proper UV coordinates.
That way I'll be able to use the Live Link in combination with the proper UV coordinates that the .IGS file create.

Or is there perhaps another way to do this without the use of any external programs?
Besides that I am very happy with Keyshot as a whole, has made 'creating some images for marketing' a lot easier, faster and better for the product engineer.
Thank you very much for your time.

thomasteger

  • Guest
Re: Solidworks imports of tubes can't be textured properly
« Reply #1 on: December 19, 2013, 06:23:13 am »
When using the IGS model, are you changing the mapping type, or do you leave it at box mapped?

Offline iahdesign

  • Newbie
  • *
  • Posts: 6
Re: Solidworks imports of tubes can't be textured properly
« Reply #2 on: December 19, 2013, 06:37:32 am »
All of the above are done with UV mapping. I found this sort of shape (a multiple bended tube) to be impossible to map with box or cylinder (or any of the other types).

thomasteger

  • Guest
Re: Solidworks imports of tubes can't be textured properly
« Reply #3 on: December 19, 2013, 06:47:29 am »
Can you share the example? I'm surprised that this works with UV mapping since IGES doesn't support texture coordinates.

Offline iahdesign

  • Newbie
  • *
  • Posts: 6
Re: Solidworks imports of tubes can't be textured properly
« Reply #4 on: December 19, 2013, 11:04:37 pm »
I don't have much understanding of what happens Thomas, but it works:

(top left: SW-import BOX. bot left: SW-import UV. top right: IGS BOX. bot right IGS UV)
(I've attached the KS file.)

Of course, with UV mapping on IGS it does change the XY scale constantly; but it keeps the texture going in comparison to the Box map where you get harsh lines where the projections meet.
All in all, the UV mapping on IGS gives me the result what I need. But I need to do renderings with this sort of products often so it would be nice if I could use the Live Link SW plugin for that somehow.
« Last Edit: December 19, 2013, 11:06:41 pm by iahdesign »

thomasteger

  • Guest
Re: Solidworks imports of tubes can't be textured properly
« Reply #5 on: December 20, 2013, 06:25:19 am »
Talking with development right now. Any chance you can send me the native SW file?

Offline iahdesign

  • Newbie
  • *
  • Posts: 6
Re: Solidworks imports of tubes can't be textured properly
« Reply #6 on: December 20, 2013, 07:41:47 am »
Thank you for looking into it!!
Not at the office at the moment, so I don't have the exact same file. But I created another random tube in SolidWorks and I'm sure it will have the same result. Also I made this as a solid, but when using surfaces in SolidWorks it will have the same effect, I already tested that earlier today.

The file I attached is made in SolidWorks 2013. But the file I used in the examples above are made in SolidWorks 2014 & Keyshot 4.3 with the latest plugin to date.
Though this kind of part just isn't mapable with the Box map and I only recently discovered that I could UV map it when it's exported as IGS. I've been doing these kind of textures in post processing for years due to these limitations in mapping of SW files. Would be so great if this could be integrated in Keyshot!

thomasteger

  • Guest
Re: Solidworks imports of tubes can't be textured properly
« Reply #7 on: December 20, 2013, 11:16:48 am »
Thanks for sharing. We are looking into this for KeyShot 5.

Offline iahdesign

  • Newbie
  • *
  • Posts: 6
Re: Solidworks imports of tubes can't be textured properly
« Reply #8 on: December 22, 2013, 10:40:00 pm »
Thank you for the update Thomas.
When can I possibly expect KeyShot 5?  ::)