Author Topic: long extrusions import issue  (Read 6473 times)

0 Members and 1 Guest are viewing this topic.

Offline PhilippeV8

  • Hero Member
  • *****
  • Posts: 1914
    • PV8-Portfolio
long extrusions import issue
« on: December 06, 2013, 06:22:01 am »
I'm still on 4.2.35 .. if going to 4.3 solves this, let me know, I'll upgrade as soon as I can ..

Other (smaller) parts import just fine.  It's the long aluminium extruded profiles it's got issues with when importing from Inventor (2014).

No matter what tesselation I set on import, doesn't help any.

Offline Chad Holton

  • Hero Member
  • *****
  • Posts: 1370
    • Portfolio
Re: long extrusions import issue
« Reply #1 on: December 06, 2013, 06:32:39 am »
Hey Philippe,

Would you care to share that inventor file (or any other with the same exact issue)? If so, please send to [email protected]

Thanks,
Chad

Offline edwardo

  • Hero Member
  • *****
  • Posts: 1116
Re: long extrusions import issue
« Reply #2 on: December 06, 2013, 06:42:51 am »
Newer versions of rhino do this with extrusions, it's annoying. Iv found if I explode the surfaces on extrusion geometry it imports ok.

Worth a try?

Offline PhilippeV8

  • Hero Member
  • *****
  • Posts: 1914
    • PV8-Portfolio
Re: long extrusions import issue
« Reply #3 on: December 06, 2013, 01:24:30 pm »
Explode surfaces ... don't think I can in Inventor .. or upon import to KS.

Ow, thnx for moving this to the right thread mods!  Sorry 'bout that...

Offline br3ttj

  • Full Member
  • ***
  • Posts: 236
Re: long extrusions import issue
« Reply #4 on: December 06, 2013, 01:57:36 pm »
Are you able to adjust the part tolerance or part accuracy in Inventor prior to exporting?  In ProE for example, especially on smaller parts, but also large parts with fine details, I'll adjust the part to a finer accuracy prior to export, whether to an .stl file or KeyShot, and I'll get more triangles with better definition on the smaller details.
« Last Edit: December 06, 2013, 01:59:38 pm by br3ttj »

Offline PhilippeV8

  • Hero Member
  • *****
  • Posts: 1914
    • PV8-Portfolio
Re: long extrusions import issue
« Reply #5 on: December 07, 2013, 04:08:55 am »
I believe level of detail is not in the inventor file.  If you open up a big assembly, it can happen that the LOD of small parts is not very acurate, but the more you zoom in on them, the better LOD they get.  So it's while working on the fly that the visual LOD gets finer .. however, I do not believe it is saved in the file.  It's probably more like a vector data file.

I can probably try to work around this by installing KS3 and importing there and then taking it to KS4 ..  I did recently switch Inventor to v2014 and KS4 to a more recent version, so it's hard to tell which of the both is causing the issue now ..

Either way, I'll pass a file to luxion on monday for them to test on.
« Last Edit: December 07, 2013, 04:10:46 am by PhilippeV8 »

Offline PhilippeV8

  • Hero Member
  • *****
  • Posts: 1914
    • PV8-Portfolio
Re: long extrusions import issue
« Reply #6 on: December 08, 2013, 11:15:11 pm »
I tried importing some old long extruded parts in KS4 and they come in with no problem.

So either it's down to an Inventor 2014 setting, or it might still be an import issue of the new Inventor file format.

Offline PhilippeV8

  • Hero Member
  • *****
  • Posts: 1914
    • PV8-Portfolio
Re: long extrusions import issue
« Reply #7 on: December 08, 2013, 11:22:21 pm »
Can not import any of the Inventor 2014 parts in KS3.3.33 so that's no work-round...

Export in Inventor to STEP doesn't help either.
Dito with IGES.
I can however save IGES as faces, but it still loses some triangles when importing.  Also with IGES I lose all file structure.

I can take the IGES into 3DVia and save as 3DS from there, which gives me a good result, but also loses the file structure ... but for now I'll take that and continue with my rendering.
« Last Edit: December 09, 2013, 01:17:43 am by PhilippeV8 »

Offline Robb63

  • Hero Member
  • *****
  • Posts: 584
Re: long extrusions import issue
« Reply #8 on: December 09, 2013, 04:48:00 am »
Newer versions of rhino do this with extrusions, it's annoying. Iv found if I explode the surfaces on extrusion geometry it imports ok.

Worth a try?

Hi Edwardo, this can be switched off in Rhino so that it doesn't happen anymore (unless you turn the feature back on). It used to drive me crazy if I forgot to explode the extrusion.

Offline Ruckus

  • Full Member
  • ***
  • Posts: 137
  • Some mistakes are too much fun to make only once!
Re: long extrusions import issue
« Reply #9 on: December 09, 2013, 04:57:04 am »
I know you said you tried different tolerance settings for the tessellation - but did you look specifically at edge length?  It is usually an irrelevant setting but for something like this, triangle edges running the full length could cause problems.  (If the the edge length is unset, or is set to 0 that could mean infinite lenght.)
« Last Edit: December 10, 2013, 04:25:35 am by Ruckus »

Offline PhilippeV8

  • Hero Member
  • *****
  • Posts: 1914
    • PV8-Portfolio
Re: long extrusions import issue
« Reply #10 on: December 09, 2013, 06:35:07 am »
I've got no such import options to KS .. just "Tessellation Quality"

Offline Ruckus

  • Full Member
  • ***
  • Posts: 137
  • Some mistakes are too much fun to make only once!
Re: long extrusions import issue
« Reply #11 on: December 09, 2013, 06:58:09 am »
Ah, sorry - I do all of my tessellation in the CAD application.  There is usually more control over the tessellation settings in those programs.

Offline PhilippeV8

  • Hero Member
  • *****
  • Posts: 1914
    • PV8-Portfolio
Re: long extrusions import issue
« Reply #12 on: December 09, 2013, 11:09:24 pm »
Upgrade to KS 431 doesn't help.  ;)