Author Topic: Normal Map Display problem in keyshot  (Read 10174 times)

0 Members and 1 Guest are viewing this topic.

Offline clau1000

  • Newbie
  • *
  • Posts: 4
Normal Map Display problem in keyshot
« on: August 15, 2013, 10:50:05 am »
Hello,

I am trying to get normal maps to display properly in keyshot, but they are acting pretty strange, and there seems to be not much of a difference when the Normal Map option is checked or unchecked, under the bump map texture type, using an advanced shader.

So I made a simple example to test the difference between maya normal map display and keyshot. It's basically a half sphere on a plane (highpoly geometry), that is baked onto a plane (lowpoly geometry), using Xnormal. Here are the results -

This is the baked normal map, showing the sphere :



Plane with normal map applied, rendered in maya viewport (with high quality) :



Plane with normal map applied by using an advanced shader, under the bump texture type, with normal map checked :




Obviously keyshot is not displaying the normal map correctly. Please help, thanks in advance. I have also attached the obj of the plane for testing purposes.
I am using Keyshot 4.1

Offline TpwUK

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 2910
Re: Normal Map Display problem in keyshot
« Reply #1 on: August 15, 2013, 12:32:07 pm »
Does it look the same from the other side of the plane too ?

Martin

Offline clau1000

  • Newbie
  • *
  • Posts: 4
Re: Normal Map Display problem in keyshot
« Reply #2 on: August 15, 2013, 10:42:08 pm »
Yes, it looks exactly the same from the other side too.

Offline TpwUK

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 2910
Re: Normal Map Display problem in keyshot
« Reply #3 on: August 16, 2013, 12:35:12 am »
Very strange, will have to wait for an expert opinion on this one.

Martin

guest84672

  • Guest
Re: Normal Map Display problem in keyshot
« Reply #4 on: August 16, 2013, 05:35:27 am »
We are looking into it.

Offline KeyShot

  • Administrator
  • Hero Member
  • *****
  • Posts: 1118
Re: Normal Map Display problem in keyshot
« Reply #5 on: August 22, 2013, 03:49:01 pm »
There was a bug (has been fixed now), where you would not be able to toggle into a normal map (so it would look like a bump map, which is what you are seeing). You can send an email to [email protected] if you want to try a beta KeyShot 4.2, where this is no longer a problem.

Offline Jo

  • Newbie
  • *
  • Posts: 1
Re: Normal Map Display problem in keyshot
« Reply #6 on: October 02, 2013, 04:22:49 am »
we have the same problem in our keyshot. but it is the newest version (4.1.35).
could it be, because it is still a trial-version?