Author Topic: Animation glitch - KeyShot realtime window very laggy after Preview rendering  (Read 3216 times)

0 Members and 1 Guest are viewing this topic.

Offline DriesV

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2429
  • Product Specialist at Luxion
Whenever you run a 'Preview' rendering from the Animation window, after it finishes (or even after you cancel it manually) the realtime window and realtime animation playback gets very laggy/stuttering. This happens regardless of the realtime rendering settings; I even get it in Performance mode.

The reasons for this issue being extremely annoying are:
  • When you hadn't saved your work on the animation yet and decide to do it after Preview rendering, the 'lagginess' gets 'embedded' into the scene. So that when you close KeyShot and reopen the scene, the realtime rendering is still very unresponsive. The scene is basically destroyed...
  • Timing animation components that are interdependent is almost impossible to do without responsive realtime feedback.

You can spend hours animating a scene, then do a Preview rendering, confirm it is good, save the scene... and then find out your scene has become impossibly slow. :-(
I just had this happen the other night.

I've encountered this issue in all scenes I ran a Preview rendering for.
I attached a sample scene where I have slow performance.

Download link:
https://docs.google.com/file/d/0Bw6BI0tv_sN8MnNhbzlPMDRteG8/edit?usp=sharing

Dries
« Last Edit: July 05, 2013, 03:17:45 am by DriesV »

Offline DriesV

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2429
  • Product Specialist at Luxion
I can confirm that re-importing the laggy scene into a new one does away with the lagginess. All animations that are applied in the laggy scene are imported too. That's some good news. :)

Dries

Offline KeyShot

  • Administrator
  • Hero Member
  • *****
  • Posts: 1128
The reason for the slow updates is that fast_update has been turned off for that file. You can adjust this in preferences under advanced.