Author Topic: Materials Library in Win7 and Saving renders in OS-X  (Read 3818 times)

0 Members and 1 Guest are viewing this topic.

Offline Pedro_Julio

  • Jr. Member
  • **
  • Posts: 67
  • Industrial Designer
Materials Library in Win7 and Saving renders in OS-X
« on: February 24, 2010, 05:42:06 am »
I've read all of the lit and done some looking around, but I'm still scratching my head over these.

1.  In Windows7 my materials library is blank.  I don't think it's a matter of the materials folder not being there, because I can't even make a new material group tab.

2. In OSX my renders do not save.  When the render is finished I get a message that says "Render Complete.  No image was saved."
« Last Edit: February 24, 2010, 05:48:32 am by Pedro_Julio »

guest84672

  • Guest
Re: Materials Library in Win7 and Saving renders in OS-X
« Reply #1 on: February 24, 2010, 06:54:01 am »
@1 - this has something to do with your KeyShot.xml file. What Windows version are you running?
@2 - you are running the demo version on the Mac. Take your license file from the Windows side and use it on the Mac side.

Offline Pedro_Julio

  • Jr. Member
  • **
  • Posts: 67
  • Industrial Designer
Re: Materials Library in Win7 and Saving renders in OS-X
« Reply #2 on: February 24, 2010, 07:27:16 am »
Win7, build 7600.

Mac side fixed....though all I did was restart.  ???  Oh well.  I'll take it.

guest84672

  • Guest
Re: Materials Library in Win7 and Saving renders in OS-X
« Reply #3 on: February 24, 2010, 10:54:04 am »
Sent you a new keyshot.xml file.

The keyshot.xml file that you have in your KeyShot Resources folder has incomplete paths in it. If you open up the new one, you can see the paths to your content. If you ever want to change that, you can do so by editing this file.

We will address this in a more elegant way with version 2.

Thomas

Offline Stein-Fredrik

  • Newbie
  • *
  • Posts: 2
Re: Materials Library in Win7 and Saving renders in OS-X
« Reply #4 on: March 30, 2010, 03:02:48 pm »
I moved all my User folders to D: and now I can't see any materials. I looked at the keyshot.xml file and the paths are still:
<materiallibrariesfolder>C:\Users\Username\Documents\KeyShot\Materials
</materiallibrariesfolder>

I tried altering the file:
<materiallibrariesfolder>D:\Documents\KeyShot\Materials
</materiallibrariesfolder>

Still no materials. I guess the above path is wrong. The documents folder is called My Documents. I tried a few variations but that didn't help either. Maybe KeyShot has lost the link to the KeyShot.xml file...I don't know so I'll stop trying at this.

I need your help.

Stein-Fredrik
« Last Edit: March 30, 2010, 03:05:12 pm by Stein-Fredrik »

guest84672

  • Guest
Re: Materials Library in Win7 and Saving renders in OS-X
« Reply #5 on: March 30, 2010, 04:53:22 pm »
What is the complete path were the materials are located?

Offline Stein-Fredrik

  • Newbie
  • *
  • Posts: 2
Re: Materials Library in Win7 and Saving renders in OS-X
« Reply #6 on: March 31, 2010, 07:29:09 am »
Problem solved ;D

I just reinstalled the program and gave the right paths during installation. So if anyone wants to move their documents off the c:drive...reinstall of KeyShot is a simple way to fix faulty paths to the KeyShot Resources folder. I also backed up the former resources folder and deleted it before reinstall of KeyShot. Now I´ll just move any materials, renderings and so on that I made before the problem occured back into the new Resources folder.

Cheers,
Stein-Fredrik
« Last Edit: March 31, 2010, 07:30:58 am by Stein-Fredrik »

guest84672

  • Guest
Re: Materials Library in Win7 and Saving renders in OS-X
« Reply #7 on: March 31, 2010, 08:25:39 am »
Cool - thanks for the update.