Author Topic: Pro Engineer Wildfire 4 Plugin  (Read 12614 times)

0 Members and 1 Guest are viewing this topic.

Offline Chrishan

  • Newbie
  • *
  • Posts: 11
Pro Engineer Wildfire 4 Plugin
« on: April 04, 2013, 03:51:34 am »
Hello,

in our company they updated all computers to Win.7 64bit. Also we now have Pro Engineer Wildfire 4 64bit.
Since this update i cannot get the plugin for Keyshot 4 to work.

OS: Windows 7 64bit
Keyshot: Keyshot 4 64bit Version 4.0.66
Plugin: keyshot4_wildfire4_plugin_2.0.exe
Pro-E: Wildfire 4  (M200)
PROTK.DAT:
Quote
NAME KeyShot4
EXEC_FILE C:\Program Files\KeyShot4\Plugins\Pro Engineer 4.0\keyshot4_proe4_plugin.dll
TEXT_DIR C:\Program Files\KeyShot4\Plugins\Pro Engineer 4.0
STARTUP     DLL
REVISION    18
ALLOW_STOP  TRUE
DELAY_START FALSE
END

Have somebody else the problem, that the plugin cannot be started?

Thx in advance
Chrishan
« Last Edit: April 04, 2013, 04:08:25 am by Chrishan »

Offline Morten Kristensen

  • root
  • Administrator
  • Full Member
  • *****
  • Posts: 130
  • Software Engineer, Luxion
Re: Pro Engineer Wildfire 4 Plugin
« Reply #1 on: April 04, 2013, 03:59:51 am »
Hello Chrishan,

What do you mean it doesn't work? Do you get an error message? Does it fail when installing?

Do you have a 32-bit wildfire installed at the moment? If this is the case then the install will not work right now. An update to the installer will be made available at a later time, which will address that issue.

Offline Chrishan

  • Newbie
  • *
  • Posts: 11
Re: Pro Engineer Wildfire 4 Plugin
« Reply #2 on: April 04, 2013, 04:10:26 am »
yes, they installed me Wildfire 4 32 bit :(
Is it possible to modify the ProTk.dat or download another dll?

Offline Morten Kristensen

  • root
  • Administrator
  • Full Member
  • *****
  • Posts: 130
  • Software Engineer, Luxion
Re: Pro Engineer Wildfire 4 Plugin
« Reply #3 on: April 04, 2013, 04:16:30 am »
In the course of the next few days a new installer for 32-bit Wildfire will be made available.

If this is not fast enough you could also install a 64-bit version of Wildfire and use the 64-bit plugin.

Offline Chrishan

  • Newbie
  • *
  • Posts: 11
Re: Pro Engineer Wildfire 4 Plugin
« Reply #4 on: April 04, 2013, 04:22:01 am »
Sorry i have to correct myself after contact our IT departement.

They said that Wildfire 4 64 bit is installed. Sorry for the confusion.

Offline Morten Kristensen

  • root
  • Administrator
  • Full Member
  • *****
  • Posts: 130
  • Software Engineer, Luxion
Re: Pro Engineer Wildfire 4 Plugin
« Reply #5 on: April 04, 2013, 04:33:17 am »
Try having a look at the readme in the plugin directory. Have you properly linked the plugin to Wildfire?

Do you get an error message?

Offline Chrishan

  • Newbie
  • *
  • Posts: 11
Re: Pro Engineer Wildfire 4 Plugin
« Reply #6 on: April 04, 2013, 04:46:40 am »
I did exactly this and it works until i want to start the foreign application. Wildfire said that the application cannot be started.
Nothing more :(

Quote
-------------------------
REGISTRATION INSTRUCTIONS
-------------------------

To start using the KeyShot plugin, please follow the instructions
below carefully.

1.  Open the Pro/ENGINEER "Options" dialog from the File menu.

2.  Under "Option", enter "protkdat" as the option name.

3.  For the option value, click "Browse ..." and navigate to your
    KeyShot 3 Pro Engineer plugin installation. This is typically
    located in "C:\Program Files\KeyShot 3\Plugins\Pro Engineer".
    Select the protk.dat file you see here and click "Open", then
    "Add/Change" and "Apply". Finally, close the dialog.
     
    (This option is saved in a .pro configuration file, which is
    typically stored in your Pro Engineer working directory)

4.  Restart Pro/ENGINEER. The KeyShot plugin should be loaded. To
    confirm this, run the "Auxiliary Applications" command under the
    Tools menu. KeyShot should appear in this list and it should be
    Running.  You can start and stop the application from this window.
    Once the KeyShot is running close the auxiliary applications
    window.

5.  To add the KeyShot buttons, simply go to "Customize Screen..."
    under Tools. Under the "Commands" tab, locate "Foreign
    applications".

    You can now add the "Render", "Settings", "Update" and
    "Mechanisms" buttons to the ProE interface by drag and dropping
    these buttons directly onto the toolbar or to a new menu or
    flyout, which also can be made under the Commands dialog.

Offline Morten Kristensen

  • root
  • Administrator
  • Full Member
  • *****
  • Posts: 130
  • Software Engineer, Luxion
Re: Pro Engineer Wildfire 4 Plugin
« Reply #7 on: April 04, 2013, 05:13:14 am »
I have relayed your issue to our guy responsible for plugins.
Hopefully we'll find a solution soon.

Offline Chrishan

  • Newbie
  • *
  • Posts: 11
Re: Pro Engineer Wildfire 4 Plugin
« Reply #8 on: April 04, 2013, 05:14:17 am »
Thank you for your help!

Greetings from Germany!
Chrishan

Offline Chrishan

  • Newbie
  • *
  • Posts: 11
Re: Pro Engineer Wildfire 4 Plugin
« Reply #9 on: April 09, 2013, 07:21:52 am »
After many trys i get it to work.

I ask the IT department to reinstall Keyshot and the plugin. With the Administrator Acc. (not run as...)

Also we installed the following runtime library:
http://download.microsoft.com/download/8/B/4/8B42259F-5D70-43F4-AC2E-4B208FD8D66A/vcredist_x64.EXE


« Last Edit: April 09, 2013, 08:58:29 am by Chrishan »

Offline Morten Kristensen

  • root
  • Administrator
  • Full Member
  • *****
  • Posts: 130
  • Software Engineer, Luxion
Re: Pro Engineer Wildfire 4 Plugin
« Reply #10 on: April 09, 2013, 07:41:36 am »
..you made it work?

Offline Chrishan

  • Newbie
  • *
  • Posts: 11
Re: Pro Engineer Wildfire 4 Plugin
« Reply #11 on: April 09, 2013, 08:59:51 am »
Yes, i dont know why my post was not complete. But i modified it now for users with the same problem!

Best Regards
Chrishan

Offline Morten Kristensen

  • root
  • Administrator
  • Full Member
  • *****
  • Posts: 130
  • Software Engineer, Luxion
Re: Pro Engineer Wildfire 4 Plugin
« Reply #12 on: April 09, 2013, 10:59:51 am »
I'm glad you figured it out. Nicely done!