Author Topic: KeyShot 4 Plugin Crashes with Sub Assemblies  (Read 6334 times)

0 Members and 1 Guest are viewing this topic.

Offline m2tts

  • Full Member
  • ***
  • Posts: 211
KeyShot 4 Plugin Crashes with Sub Assemblies
« on: March 07, 2013, 07:24:54 am »
I have a SW assembly that contains two subassemblies. When using the Keyshot 4 plugin; choosing "render"; SW crashes. Works fine with assemblies with just parts.

The assembly with subassemblies imports just fine; but SW will crash if I try to update with live linking. KeyShot says it's waiting for a connection to import the updated geometry.
« Last Edit: March 07, 2013, 07:37:09 am by m2tts »

guest84672

  • Guest
Re: KeyShot 4 Plugin Crashes with Sub Assemblies
« Reply #1 on: March 07, 2013, 11:52:25 am »
Make sure you install the latest plugin from the "Plugin" section or www.keyshot.com/plugins.

Offline m2tts

  • Full Member
  • ***
  • Posts: 211
Re: KeyShot 4 Plugin Crashes with Sub Assemblies
« Reply #2 on: March 07, 2013, 03:40:57 pm »
Hi Thomas, I've updated the plugin to 2.0.1 and it still crashes SW.

guest84672

  • Guest
Re: KeyShot 4 Plugin Crashes with Sub Assemblies
« Reply #3 on: March 07, 2013, 04:37:11 pm »
Any chance you can share the file? Send directly to me via keyshot.wetransfer.com.

Offline m2tts

  • Full Member
  • ***
  • Posts: 211
Re: KeyShot 4 Plugin Crashes with Sub Assemblies
« Reply #4 on: March 07, 2013, 06:31:41 pm »
Hey Thomas, I have transferred the assemblies causing the trouble. Please treat these as confidential.

I have experimented with other test assemblies and while they don't crash SW, they also do not show any Live Linking; even though that is checked. I was trying to recreate the crash as I had a hunch it was because of using "use a sub-assemblie's explode" in a higher level assembly explode view. That doesn't seem to be the issue however.

guest84672

  • Guest
Re: KeyShot 4 Plugin Crashes with Sub Assemblies
« Reply #5 on: March 08, 2013, 06:55:40 am »
We fixed the issue. I e-mailed you the links, and updated the links on www.keyshot.com/plugins.

Please let us know how it works.

Offline m2tts

  • Full Member
  • ***
  • Posts: 211
Re: KeyShot 4 Plugin Crashes with Sub Assemblies
« Reply #6 on: March 08, 2013, 07:23:18 am »
The new pluging solves the crashing issue, but it has broken Live Linking. We realllllly like the new Live Linking feature as it can easily show models in various states of motion (flipping subassemblies), and exploded views.

guest84672

  • Guest
Re: KeyShot 4 Plugin Crashes with Sub Assemblies
« Reply #7 on: March 08, 2013, 11:37:26 am »
Spoke with the developer. You can select the changed parts and then hit update. This will then force the update and move the "changed" parts over.

Offline m2tts

  • Full Member
  • ***
  • Posts: 211
Re: KeyShot 4 Plugin Crashes with Sub Assemblies
« Reply #8 on: March 08, 2013, 01:17:26 pm »
Yes, that's the ticket. Works now.

Thanks!

guest84672

  • Guest
Re: KeyShot 4 Plugin Crashes with Sub Assemblies
« Reply #9 on: March 08, 2013, 02:57:31 pm »
Great - right now we can't detect these changes. Same when you just change the color on a part. You will need to select it to force the update.

We are of course looking at improving this, and will hopefully able to auto-detect these types of changes.

Offline m2tts

  • Full Member
  • ***
  • Posts: 211
Re: KeyShot 4 Plugin Crashes with Sub Assemblies
« Reply #10 on: March 08, 2013, 04:34:47 pm »
But it was doing this before the 2.0.1 update. I know I saw an assembly that a rotating part in it update without highlighting it first. Also saw an exploded view update with an assembly with just parts in it.

guest84672

  • Guest
Re: KeyShot 4 Plugin Crashes with Sub Assemblies
« Reply #11 on: March 08, 2013, 04:36:46 pm »
ok we will take a look.