Author Topic: Subassemblies not recognized on import  (Read 3780 times)

0 Members and 1 Guest are viewing this topic.

Offline mgrant

  • Newbie
  • *
  • Posts: 21
Subassemblies not recognized on import
« on: January 30, 2013, 11:34:37 am »
I have a large assembly (~2000 parts and ~1.3GB when it is in KS) that I set up for rendering a product in several different configurations.  To make things easier on myself I have nine subassemblies to allow me to easily show and hide various components.  However, when I import into KeyShot, several of the subassemblies aren't maintained and their parts are simply dumped into the tree.  When I try to import using the plugin SolidWorks immediately crashes.  I'm running SW2012 and KeyShot 3.3.33.
« Last Edit: January 30, 2013, 11:44:19 am by mgrant »

guest84672

  • Guest
Re: Subassemblies not recognized on import
« Reply #1 on: January 30, 2013, 11:45:37 am »
It would be best if you could share this model with us so we can take a look. It is difficult to determine what the issue may be without seeing the data. You can use wetransfer.keyshot.com to do the transfer.

Thanks,
Thomas

Offline mgrant

  • Newbie
  • *
  • Posts: 21
Re: Subassemblies not recognized on import
« Reply #2 on: January 30, 2013, 12:18:46 pm »
I'll have to check into the feasibility of transferring the files.  Confidential data and all.  I'm assuming that you would want the Solidworks assembly not the bip.

guest84672

  • Guest
Re: Subassemblies not recognized on import
« Reply #3 on: January 30, 2013, 12:21:19 pm »
correct. The whole assembly. We treat all data with the utmost confidentiality.

Offline mgrant

  • Newbie
  • *
  • Posts: 21
Re: Subassemblies not recognized on import
« Reply #4 on: January 30, 2013, 12:35:18 pm »
I went through the bip more closely and found that KeyShot had maintained the original structure and then duplicated the parts in the assemblies and dumped them into the main tree.  I was able to prune out the duplicates and still maintain the structure that I had created.

I haven't been able to get approval to upload anything yet, and am unsure of how likely it will be, but at least there is a work around of sorts.