Author Topic: Single Solid Edge Parts will not Import in 3.0.99  (Read 4839 times)

0 Members and 1 Guest are viewing this topic.

Offline maymay

  • Jr. Member
  • **
  • Posts: 78
Single Solid Edge Parts will not Import in 3.0.99
« on: February 20, 2012, 09:49:32 am »
SE assemblies open fine, but if you open/import a single SE part, it crashes as soon as you hit OK on the import options dialog. I've tried several different SE parts ranging in complexity, none will open. I just installed the latest 3.0.99 update. Does not work when adding to a scene that has geometry already in it either.

All of our parts are on the network. I tried opening a part saved locally, still no luck.
« Last Edit: February 20, 2012, 09:51:45 am by maymay »

Offline jeffw

  • Full Member
  • ***
  • Posts: 173
Re: Single Solid Edge Parts will not Import in 3.0.99
« Reply #1 on: February 20, 2012, 04:31:51 pm »
I also use SolidEdge and tested this and had the same experience. However I found that dragging part files from windows explorer into the KeyShot scene will import without problem. I actually always use SimLab composer to convert my SE files into OBJ and then import to KS.

Offline maymay

  • Jr. Member
  • **
  • Posts: 78
Re: Single Solid Edge Parts will not Import in 3.0.99
« Reply #2 on: February 21, 2012, 11:23:41 am »
Thanks, Jeff. I'll give that a try. Out of curiousity, why do you use SimLab to convert?

guest84672

  • Guest
Re: Single Solid Edge Parts will not Import in 3.0.99
« Reply #3 on: February 21, 2012, 04:17:16 pm »
I just tried this and had no problems. I'm using Win 7 64bit.

Offline jeffw

  • Full Member
  • ***
  • Posts: 173
Re: Single Solid Edge Parts will not Import in 3.0.99
« Reply #4 on: February 23, 2012, 10:30:24 am »
I am also on Win7 64 bit.

As far as why do I use SimLab, it's nothing against Keyshot, it more about SolidEdge's lack of export and it's a bit complicated but here goes.

I often need to import a new part into an existing Keyshot scene and have it be in an exact position relative to the existing KS model. Let's say I import a native SolidEdge assembly to KS. It imports fine and shows all the parts fine. Later I add a new part to my original top level SolidEdge assembly. I don't want to import the whole top level again I only want the new part but it needs to keep its position relative to the top level model. The only way to do this in SE other than copying the file is to delete out all the other parts and save the file or SE will not register the change. But I don't want to save this change because it is my top level assembly and needs to have all parts. If I bring in the new top level SE assembly into SimLab I can delete as many parts as I want and then export as an OBJ at that state and it retains its spatial relationship to the original assembly. It doesn't matter if the SimLab file is saved or not and I never risk messing up my top level SE file by using it. I import this OBJ to Keyshot and it drops right into position on the original model which was also brought in with SimLab.

guest84672

  • Guest
Re: Single Solid Edge Parts will not Import in 3.0.99
« Reply #5 on: February 23, 2012, 11:08:16 am »
You can simply replace the entire assembly by using the "retain material" option upon second import.