Author Topic: Keyshot 7 Not Opening SolidWorks Files  (Read 542 times)

0 Members and 1 Guest are viewing this topic.

Offline degruch

Keyshot 7 Not Opening SolidWorks Files
« on: November 06, 2019, 03:10:39 am »
Hi all,

I am a long time user of Keyshot and had this issue a few years back on my work computer when KS6 was released. At the time Thomas solved it for me, I think, but I have recently fired up my old KS6 and KS7 licenses to do some work at home and found the same old problem. In fact, I have never solved this problem on my home computer, consequently, I've not been able to open a file on KS6 or KS7 ever!

If I try to import an SW file direct into KS I used to get a message tell me there was "no 3D data found", but now I get this: [KS Bug 001.jpg]

If I try 'Send to Keyshot' from SW via the plugin it hangs forever: [KS Bug 002.jpg]

If I 'Export to Keyshot' from SW via the plugin, close SW and then open the KS file by double clicking I get the first problem again.

These are automotive CAD models, so they're not small, but I'd expect KS to be slow, not refuse to open them at all. Does anyone know what's happening here, or tips to work around it? I bought this software 2 years ago and am yet to open a file with it, lol!

1. Computer make and specs:
    NVIDIA Quadro M5500
    Intel Xeon CPU E3-1505M V5 2.80GHz
2. KeyShot 7.3.40
3. SolidWorks 2019 SP1.0
4. Step-by-Step instructions to re-create the issue you are seeing.
    As described above
5. Screenshot(s) showing the issue that you are seeing.

Any help would be much appreciated, thankyou!  :-[

« Last Edit: November 06, 2019, 03:12:36 am by degruch »

Offline sloanelliot

Re: Keyshot 7 Not Opening SolidWorks Files
« Reply #1 on: November 06, 2019, 09:28:08 am »
I've had this same issue and never been able to quite figure out why because it varies from case to case. In most cases, it was fixed by either using the SolidWorks plugin vs. direct import, or, NOT using it when the plugin fails.

I do know, one time the fix was to uncheck "Include NURBS data" in the plugin options within SolidWorks. Other times, I've just had to change the file format (to STEP, IGES, Parasolid, etc. -- occasionally even STL), but that can wreak havoc on your models sometimes..

It also doesn't like it if your scene is paused when you initiate the link/export, but I doubt that's what's going on here.

LASTLY, even when starting a new scene / fresh link, the "Update Link" button is the only one that reliably works. It will still send the part to Keyshot even if a link hasn't been established, and for some reason works more often than the "Send to Keyshot" action will.. Zero idea why.

Ha maybe one of the above will work for you.  ;D

Offline INNEO_MWo

  • Hero Member
  • *****
  • Posts: 959
  • Total likes: 4
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: Keyshot 7 Not Opening SolidWorks Files
« Reply #2 on: November 06, 2019, 09:31:06 am »
Hello Duane.

If your Solidworks is much newer than KeyShot, I guess you have to use a neutral file format like parasolid (x_t) or Step. This should always work and give you the current configuration and all the library and toolbox parts. And also it can be used for geometry updates and several other stuff.


Offline Eric Summers

Re: Keyshot 7 Not Opening SolidWorks Files
« Reply #3 on: November 06, 2019, 09:55:23 am »
Marco hit the nail on the head, KS7 only supports up to SW 2018:

Offline sloanelliot

Re: Keyshot 7 Not Opening SolidWorks Files
« Reply #4 on: November 06, 2019, 10:03:13 am »
I have Solidworks 2019 and up until my upgrade yesterday, KS 8.2. Sadly still have these issues quite often and seemingly with no rhyme or reason. I have the latest plugin as well.

Offline degruch

Re: Keyshot 7 Not Opening SolidWorks Files
« Reply #5 on: November 07, 2019, 04:05:57 am »
Thanks everyone, I really appreciate the advice!

Unfortunately, seems Marco and Eric were correct in regard to SW2019 not working with KS7.3, as some SW2018 files I had opened fine. I did manage to make a STEP file of an SW2019 file work with some coaxing...not an optimal solution, but short of splurging on an upgrade, it is the best I can hope for right now. How do I make geometry upgrades work with a STEP though? Just save over the old STEP file with new changes?

Thanks again everyone!