Author Topic: Objects not rotating as expected  (Read 516 times)

0 Members and 2 Guests are viewing this topic.

Offline theAVator

  • Sr. Member
  • ****
  • Posts: 265
  • Acting my shoe size since 1984
Objects not rotating as expected
« on: September 04, 2019, 07:57:45 am »
I'm not certain I can share my actual model, but I put together a test file that replicates the issue and have attached it below.

My issue is that I have a group of objects that I I am animating to show an exploded view. The objects come out of the back of the main housing(Cube). I grouped the objects, made a rotation animation where the whole group(Top Group) rotates and set the axis to be the main housing(Cube). I then exploded out the internals(Cylinders 1-4). Then I want to whole group (internals still exploded) to rotate back into position so I can explode the rest of the internals out the front.

The issue is that the exploded internals don't continue to rotate around the housing(Cube) even though it is set as the rotation Pivot Point. Instead they just rotate in place around their own axis.

Any ideas? Do I have to switch and create new rotation animations for each exploded part now too instead of being able to rotate the group they are a part of??

Keyshot 8.2.80
Window 10 Enterprise (1803)
Xeon E5-1660
64GB Ram
NVIDIA Quadro M4000
« Last Edit: September 17, 2019, 03:04:59 pm by Bruno F »

Offline theAVator

  • Sr. Member
  • ****
  • Posts: 265
  • Acting my shoe size since 1984
Re: Objects not rotating as expected
« Reply #1 on: September 04, 2019, 08:40:08 am »
Substituting a Turntable for the main rotation of the group results in the same unwanted outcome.

Creating individual rotation animations for the internals actually skews the geometry and doesn't end up in the right place either (though a smidge closer to where it should be).

Offline theAVator

  • Sr. Member
  • ****
  • Posts: 265
  • Acting my shoe size since 1984
Re: Objects not rotating as expected
« Reply #2 on: September 04, 2019, 09:19:04 am »
I think I have a solution...
It seems to have to do more with the translation of the internals than the actual rotation bit. When the internals are translated, the Axis orientation is one way, but when you rotate it, that axis changes with it so the parts are no longer translated along the same axis in both positions.  So they should be set to use the local axis while the group as a whole needs to rotate in the global axis.

Offline Bruno F

  • KeyShot Support
  • Full Member
  • *****
  • Posts: 169
Re: Objects not rotating as expected
« Reply #3 on: September 11, 2019, 03:01:27 pm »
Hello theAvator,

That is correct. For this type of animation, it is best if the translation animations are using Axis Orientation = Original Local.