Author Topic: Settings for avoiding a mac falling into sleep mode  (Read 609 times)

0 Members and 1 Guest are viewing this topic.

Offline mercury

  • Newbie
  • *
  • Posts: 13
Settings for avoiding a mac falling into sleep mode
« on: March 20, 2019, 02:58:01 pm »
Hello folks,

I am quite new to keyshot and as well this is my first post in this forum. So actually I have problems with settings. My goal was to let my mac (MacOS Mojave) do the render job over night. I am on KS V8 latest.

Now whatever I do, I could not prevent the from fallen into (I guess this must be) sleep mode, because very short, after I leave the Computer (phisycally or after closing remote access) the system seems to dramatically decrease render performance.

Now what I found is for example this forum post
https://www.keyshot.com/forum/index.php?topic=21917.msg96932#msg96932

but finally I could make it work.

There are plenty of mixed settings, and I wonder if anybody has got a kind of setting plan, step by step guide that works?

First of all regarding left alone machine:

Does it make any difference for render performance if I do it in background (keyshot setting) or directly? Which one to choose? Or for that case it would be better to use the queue for render?

What settings do you use within mac energy options, to let the mac render through the night?

Are there any other settings inside KS to prevent the mac falling into sleep?

I would really appreciate any help with this.

Thanks a lot in advance
mercury



Offline richardfunnell

  • Sr. Member
  • ****
  • Posts: 379
  • ID Rendering + KeyShot Workflow
    • My page
Re: Settings for avoiding a mac falling into sleep mode
« Reply #1 on: March 20, 2019, 06:42:03 pm »
Hi Mercury!

Welcome to the forum!

I use an app called Amphetamine (Mac App Store link https://itunes.apple.com/us/app/amphetamine/id937984704?mt=12) to keep my computer from going to sleep when I'm letting something run. I haven't tried the App Nap disabling yet, but that's probably another good step.

Background/queue rendering shouldn't make a difference, but I may be wrong on that. I let my queue sit overnight with no issues.

Another handy app for keeping my laptop cool is smcFanControl (https://www.eidac.de) which allows you to set the fan speed, which in my case is maximum during any rendering. Maybe that will help the MacOS from throttling your CPU speeds?

I definitely don't have all the answers on this but I hope it helps!

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1448
Re: Settings for avoiding a mac falling into sleep mode
« Reply #2 on: March 21, 2019, 05:41:43 am »
I'm interested in wy just disabiling all the options in the energy saving preference pane doesn't solve this? I don't run KS on a mac, my work uses Pc's, but I know when I was using other render engines, as long as the app was active and rendering and I turned all the options to off or never it wouldn't fall asleep.

Also make sure that you don't have a schedule set to force the computer to fall asleep under the "Schedule" button in the pref pane of OSX.

I second the use of SMCFanControl, very easy to use and works well.

Offline mercury

  • Newbie
  • *
  • Posts: 13
Re: Settings for avoiding a mac falling into sleep mode
« Reply #3 on: March 21, 2019, 06:16:20 am »
Hi richardfunnell and mattjgerard,

thank you for your help. I will give amphetamine a try. Looks quite good. Yesterday I already tried jiggler as well, but however it didn't work, although the mouse mooved as expected.

In my opinion those mac settings are confusing. There are too many naps and stuff, and I really don't know how they affect together.

@richardfunnel
Amphetamine seems to make the overriding of default sleeps and naps easy. So I am hopefully. This question was about an iMac. There is no fan working I guess. Or it is not notable? In my Macbook I have the fan running as soon as rendering starts, like you said, but I didn't mention any render performance decrease.

@mattjgerard
Quote
I'm interested in wy just disabiling all the options in the energy saving preference pane doesn't solve this?
Haha, yes. I am interested in that too. Maybe because it is a mac. :D

I will check if tonight Amphetamine will do the job. :)

 

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1448
Re: Settings for avoiding a mac falling into sleep mode
« Reply #4 on: March 21, 2019, 07:44:18 am »
There was another thread about this very thing not too long ago, and I recall them using Amphetamine and reported good results with overnight rendering.

Just to clarify though, using the background render vs the regular in app render shouldn't pose any difference in time. I think the background rendering might be a bit more stable, as it is handing the render over to a different service and won't be screwed up if Keyshot crashes for some reason.

Offline mercury

  • Newbie
  • *
  • Posts: 13
Re: Settings for avoiding a mac falling into sleep mode
« Reply #5 on: March 21, 2019, 12:21:24 pm »
@mattjgerard
I have just tested amphetamine right now, and it didn't solve it for me until now. It is really crazy. I try to render an animation.

The time for 1 frame is about 6 Minutes, when rendering directly.

As soon as I do anything else with the computer I mentioned a heavy performance decrease. Now having amphetamine running and leaving the mac with only KS render running, I check a few hours later by remote access and see that a single frame took 45 minutes for rendering.

@richardfunnel

When you let your mac render alone, how is the display behavior set up?

There are 2 Options for Display:

One is inside Macs energie settings: Did you set this to "never" sleep?

The other one is inside Amphetamine "Allow Display to fall asleep"

How is your setup?

As I would prefer to have KS rendering without active display, I have hat settings related to that. Now as it still doesn't work I try with having those setup to never fall asleep for the display.

It is really remarkable having such an easy thing so difficult to setup...

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1448
Re: Settings for avoiding a mac falling into sleep mode
« Reply #6 on: March 21, 2019, 12:43:37 pm »
Which iMac do you have? They all have fans, they are just managed to provide the least amount of noise. I would see if you can look at the CPU load vs temp and see if there is some heavy thermal throttling happening. That's what it sounds like.

Offline mercury

  • Newbie
  • *
  • Posts: 13
Re: Settings for avoiding a mac falling into sleep mode
« Reply #7 on: March 21, 2019, 01:03:54 pm »
I have a
iMac (Retina 5K, 27 Zoll, Late 2015)
3,2 GHz Intel Core i5
32 GB 1867 MHz DDR3

But I guess this isn't related to the heat because any time I am working at the iMac render performance is good. As soon as I leave it it is like it falls asleep.

For example: actually the iMac is running in the office. When I am looking at it with screensharing the perfomance is like woken up. All the time I am connected to the office iMac it renders in time, means a frame in about 6 minutes.

When I quit screensharing session and get back to it 50 minutes later, the last frame ist still rendering with let's say 45 Minutes.

This is strange, but the performance loss isn't linear. It is like happening in Moment of inactivity. Maybe like MacOS isn't mentioning that KS is working, when there is no other action on system.

is there any other setting inside ks related to this except the CPU performance setting in the above dropdown menue?

Offline mercury

  • Newbie
  • *
  • Posts: 13
Re: Settings for avoiding a mac falling into sleep mode
« Reply #8 on: March 21, 2019, 01:05:45 pm »
In addition to that:

Is there a possibillity to pause a render job and close KS, just to follow up rendering on at later time?

Offline mercury

  • Newbie
  • *
  • Posts: 13
Re: Settings for avoiding a mac falling into sleep mode
« Reply #9 on: March 21, 2019, 02:29:38 pm »
It is really strange.

This image shows CPU activity while it is alone, and then after connecting with screensharing.

Seems that it falls asleep anyway, as soon as I leave it alone. So in this case Amphetamine does not affect.

Offline mercury

  • Newbie
  • *
  • Posts: 13
Re: Settings for avoiding a mac falling into sleep mode
« Reply #10 on: March 22, 2019, 04:30:49 am »
Stopping app nap solved the main problem for me. But sorry I made a post in wrong Thread:

Quote
ok, actually stopping "app nap" seems to solve that. But other than described in some tuts in web, restart the app didn't work, I needed to restart the Computer.

And as well I think amphetamine and energie settings still do have influence in rendering performance, because I did let amphetamine run a 10 hours Session (I don't remember exactly, might have beenn 9), and when I get back to office, there were 2/3 (about 88 frames) of whole render job fulfilled, but the latest frame already did take about 30 minutes and the amphetamine session was closed already.

My target would be to have the display of and let the machine render through the night. I guess to reach this it needs some more trials to meet the exact setup.

If I found a working setup I will post here

Thanks for participating im my problems.
Report to moderator     79.227.237.130

Offline mercury

  • Newbie
  • *
  • Posts: 13
Re: Settings for avoiding a mac falling into sleep mode
« Reply #11 on: March 22, 2019, 01:04:14 pm »
finally stopping app nap didn't solve the problem at all. :(

Still having issues with low render/cpu performance.

I am not sure, but probably the screensharing mode seems to activate sleep modus after quitting it from remote computer.

This is really silly

Online TGS808

  • Sr. Member
  • ****
  • Posts: 315
Re: Settings for avoiding a mac falling into sleep mode
« Reply #12 on: March 22, 2019, 05:23:44 pm »
I'm interested in why just disabiling all the options in the energy saving preference pane doesn't solve this?

It does solve it. I have no idea why it's wouldn't work for mercury. I have everything set to not sleep. As I mentioned in the other post, (that he linked to above) I just turn the screen brightness all the way down and let it run. It renders and it does not stop and go to sleep.

Offline mercury

  • Newbie
  • *
  • Posts: 13
Re: Settings for avoiding a mac falling into sleep mode
« Reply #13 on: March 23, 2019, 02:16:04 am »
@TGS808

thanks for sharing your settings. Probably the sleeping display option would be the problem. Yesterday I have had tried to render overnight with letting the display falling asleep. That seems not to work. Even while amphetamine is running.

right now I am testing your energie settings.

But I have a suspicion: I remotly manage the office (render) Mac by Macs screensharing app (don't know if that's the right name, in german it is called "Bildschirmfreigabe" - see attached image).

Actually I see that as soon as I disconnect the screensharing, the performance slows down. It is like the mac thinks that as I am remote, the office Mac don't need to work any longer. :D

Saying that, I did have the option "wake for network access" activated.

Now trying with your settings.

Anyway this is a stupid situation. Managing that easy challenge seems to be very difficult. There are plenty parameters the must meet each other in the right settings:

rendering main/background/queue
having the process in front/back window
having app nap activated or not
having an "avoid sleep mode" app like amphetamine running or not
allow screen falling asleep
other energie settings...

Online TGS808

  • Sr. Member
  • ****
  • Posts: 315
Re: Settings for avoiding a mac falling into sleep mode
« Reply #14 on: March 23, 2019, 09:46:17 am »
@mercury

Yes, for some reason letting the screen sleep (even if the hard drive is set to not sleep) does seem to make a difference. I noticed this early on using KeyShot while rendering out animation frames. I could see that the time between completed frames when the screen was sleeping was much, much longer than the times between completed frames when it was not. As soon as I woke the screen up it started rendering much faster. I can not explain why this is, only that it is. It is for that reason that I turn the screen brightness all the way down rather than having the screen turn off.

FYI... When I do this I am always using background rendering and the render window is the front window. I do not have any screen sharing software installed. I do not have any "sleep instigation/avoidance" apps on my Mac such as app nap or amphetamine. I am only using the energy saver setting to tell it to not sleep. I do not use the built in screen saver either. I just turn the screen brightness down and let KeyShot run.

Side note: At my office I use network rendering. When one of the Macs on the network goes to sleep, it disappears from the list of available slave machines and stops working. Because of that, I have set all of them to never sleep just like my single Mac at home. That works. I do have those using the built in screen saver. When the screen saver activates it does not affect the Macs performance on the network. It continues to render without issue.