Author Topic: Ground Plane woes  (Read 1343 times)

0 Members and 1 Guest are viewing this topic.

Offline andy.engelkemier

  • Sr. Member
  • ****
  • Posts: 409
Ground Plane woes
« on: March 17, 2019, 10:27:10 am »
This is a ground plane shadow. Not very useful. I've used it before without issues, so no idea what's going on here.

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 825
  • David Merz the Third
    • MerzTheThird
Re: Ground Plane woes
« Reply #1 on: March 17, 2019, 06:48:24 pm »
Hmmm, try checking a couple of things.

A.) Are you using a physical ground plane (that you added yourself or from the edit > add ground plane menu?
B.) If so, check your 'environment' tab and make sure you turn off the "ground shadows" there. It might be causing some interaction.
C.) If that's not the case, and you're not using a physical ground plane, what is the size of your ground plane in the environment tab, is it appropriate for your scene? I have had similar issues where mine was super super large and seem to take much longer to render clean.
D.) What are your lighting settings, are you using interior/product?

Offline andy.engelkemier

  • Sr. Member
  • ****
  • Posts: 409
Re: Ground Plane woes
« Reply #2 on: March 18, 2019, 11:29:44 am »
I may have narrowed it down.
It didn't matter if I used the ground plane or not. The ONLY way for me to get a decent shadow is to ensure the environment background is white. This means, of course, my shadows aren't black.

So we ended up rendering every object for every version with a trick I recently learned where I render the scene as a black emissive material with "visible to camera" off. I had to jack up number of refractions to 128 to be safe. Around 110 seemed fine for most, but you never know at full size.

I'm using that as a black and white image to create a selection in photoshop, then I can make the shadow from that. I need transparent shadows, NOT just multiply. That works for same image only. If you need a transparent image in the end, you need black shadows. It's one of my biggest keyshot woes.

So, not Quite sure what was going on with that. I do have a groundplane in the scene that is quite large, but it's not visible during shadows.

Online DriesV

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2425
  • Product Specialist at Luxion
Re: Ground Plane woes
« Reply #3 on: March 18, 2019, 12:21:45 pm »
Hi Andy,

This issue with the artifacts in the ground shadows only occurs when using Custom Control. I presume that is what you are rendering with?
The issue is related to anti-aliasing. Basically, at default settings, Custom Control is having a hard time differentiating the black shadow pixels from the black Environment background color.
Increasing the Anti Aliasing quality in the Custom Control settings usually fixes the problem.

For what it's worth, Maximum Samples does not show these artifacts.

Dries
« Last Edit: March 18, 2019, 12:54:24 pm by DriesV »

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 825
  • David Merz the Third
    • MerzTheThird
Re: Ground Plane woes
« Reply #4 on: March 18, 2019, 12:44:30 pm »
Hi Andy,

This issue with the artifacts in the ground shadows only occur when using Custom Control. I presume that is what you are rendering with?
The issue is related to anti-aliasing. Basically, at default settings, Custom Control is having a hard time differentiating the black shadow pixels from the black Environment background color.
Increasing the Anti Aliasing quality in the Custom Control settings usually fixes the problem.

For what it's worth, Maximum Samples does not show these artifacts.

Dries

Good to know, Dries. Thanks for the clarity.

Also, another thing to note about shadows and transparent BG, Andy is Interior mode won't give you the transparent BG like you expect to get when you're using Product Mode, at least that's been my experience, not sure if that's applicable here, but it was something I learned recently.

Offline andy.engelkemier

  • Sr. Member
  • ****
  • Posts: 409
Re: Ground Plane woes
« Reply #5 on: March 18, 2019, 02:32:14 pm »
Thanks Dries. I wondered about that a little, but lots due tomorrow.
I think realtime render also may fix the banding you get since it will naturally be dithered.

Offline Bruno F

  • KeyShot Support
  • Full Member
  • *****
  • Posts: 169
Re: Ground Plane woes
« Reply #6 on: April 17, 2019, 05:04:50 pm »
Since there have been no replies or updates to this post for more than two weeks, it's been locked.
You may open a new post for additional assistance.

Post closed by Luxion Support Team