Author Topic: Environment size affects camera clipping distance inside geometry view  (Read 1107 times)

0 Members and 1 Guest are viewing this topic.

Offline Peticel

  • Newbie
  • *
  • Posts: 8
Hi,

I discovered a bug in the Geometry View window ( KS 7 and 8 ).

How to recreate:
Open a new scene, go to Edit -> add geometry -> add whatever you like or import something.
Select object and edit geometry. With the edit geometry window open, change the size of the environment.
If you go over a certain threshold, the camera starts clipping through the model (like in Blender when you zoom in too close).

I had this problem for a long time as I had a Startup scene set up and the environment was pretty big and I could never see anything in the geometry view. Also seemed to affect the selection outlines in version 7. In version 8 they seem to be fixed.

I have attached some images to show the problem.

Best regards.

Offline MWo

  • Hero Member
  • *****
  • Posts: 904
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
You can just use the same method in geometry view as in real time render port - ctrl + alt + RMB to set a new camera target. (this works since every version the geometry view exists)


Hope that helps


Cheers
Marco

Offline Peticel

  • Newbie
  • *
  • Posts: 8
Hi MWo,

Thank you for the reply.
I know how to work around it now.
The problem is that if you go over a threshold with the environment size, you can not zoom in to see the geometry anymore.
Also Ctrl+Alt+RMB works (selects a new camera target) but the clipping is still present.

I tought this would maybe help someone who had the same problem and had no idea what was causing it.
Also maybe it will be patched.

Best regards.
« Last Edit: March 10, 2019, 10:37:32 pm by Peticel »

Offline MWo

  • Hero Member
  • *****
  • Posts: 904
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
So, we'll need kind of an "environment to work or setup" that isn't as large as the final used one?!?

Offline Bruno F

  • KeyShot Support
  • Full Member
  • *****
  • Posts: 169
Since there have been no replies or updates to this post for more than two weeks, it's been locked.
You may open a new post for additional assistance.

Post closed by Luxion Support Team