Author Topic: Splotchy shadows wont go away  (Read 1738 times)

0 Members and 1 Guest are viewing this topic.

Offline Poog

  • Newbie
  • *
  • Posts: 5
Splotchy shadows wont go away
« on: March 04, 2019, 09:32:36 am »
Hey folks, as part of a long project I'm finally at the end; the product itself struggled with tiny grain but it was resolved with interior mode. The finale is the product going into the package, so it needs the same settings. However, now I get odd, splotchy shadows before the package closes. I need it done asap, so here's my file, can anyone point me in the right direction?

256 samples, tried both 2.5 and 3 shadow quality, and ray bounces at 12 to match what the product had.

Offline designgestalt

  • Full Member
  • ***
  • Posts: 189
Re: Splotchy shadows wont go away
« Reply #1 on: March 04, 2019, 10:46:32 am »
hey Poog,
besides the fact, that I do not understand, what your bump map on the box is doing for you, (it is huge and the mapping type is cylindrical! it does not really show any effect, but it will for sure have an effect on the light it is reflecting. Either put it on properly or disable it! but this is not your problem!) I would change the lighting from "interior" to "product mode" and rather mess with the environment setting and the lighting a bit to bring that ground shadow back in again!
I guess this is the quickest solution for the moment being ! Your rendertimes will also be three times faster, if I compare on my machine, which, for an animation is crucial!
Personally, I would also change the material type for the box to plastic or advanced (personal pref, I like it better as it gives me more options to play with the material! ) and bring that white down just a tad (maybe 97%, nothing is that white !)
there are few other things here, i.e. your product "sticks" in the floor, which results in the slight white "brim" at the very bottom of the box.
With the lighting set to "Product Mode" this is not so obvious!
hope that helps!
cheers
designgestalt

Offline Poog

  • Newbie
  • *
  • Posts: 5
Re: Splotchy shadows wont go away
« Reply #2 on: March 04, 2019, 11:18:13 am »
Yeah I already got rid of the bump map though that didn't help.  I'm trying to stay on interior because I rendered the other videos in interior, so the lighting all has to match by the deadline, as its a direct continuation of another animation I did. I was also just changing the material, I figured it would be off.

As for the white, I am aware, I just had to remove the box image due to NDAs. I just need that weight splotchy shadow on top of the box to go away more than anything else.
« Last Edit: March 04, 2019, 11:46:28 am by Poog »

Offline designgestalt

  • Full Member
  • ***
  • Posts: 189
Re: Splotchy shadows wont go away
« Reply #3 on: March 04, 2019, 12:29:10 pm »
Basically what that comes from is the high number of bounces in your ray bounces, as well as the global illumination!
Both numbers reflect how often the rays are reflected, or in the case of the ray bounces also refracted.
the global illumination is the indirect light bouncing in between 3D geometry.
So in your case the light is going nuts in between that little lid and the main box. reducing the number of rays does not really solve the problem as the global illumination is interacting with the ray bounces.
the second issue here is the math with which the interior mode is calculated (in comparison with the product mode).
If you copy the numbers  of ray bounces and global illumination from interior mode to product mode, you will see, that it does not show that problem.

so to make a long story short: you have to die one way or the other:
- you can turn the global illumination off in the interor mode (which I would not do, as your problem with the interfering box with the ground plane becomes more obvious)
- you live with what you have ( I have a very fast machine and let it render up to 2000 samples and teh shadow is not "clean")
- you render a short sequence in product mode, combine your two scenes quickly and see if you can live with the result ( I am quite sure, it should be ok, try it!)

that is unfortunatelly all I can say for the moment.
maybe someone has another idea?
cheers
designgestalt

Offline Poog

  • Newbie
  • *
  • Posts: 5
Re: Splotchy shadows wont go away
« Reply #4 on: March 04, 2019, 01:53:54 pm »
Maybe I can get away with rendering the box in product mode as you suggest and just use the magic of video editing have it cover the product we have. Its not a perfect solution, but it could work. Any other thoughts would be greatly appreciated.

Offline designgestalt

  • Full Member
  • ***
  • Posts: 189
Re: Splotchy shadows wont go away
« Reply #5 on: March 04, 2019, 02:01:37 pm »
I would give it a try, I am quite sure the result will be ok!

Offline INNEO_MWo

  • Hero Member
  • *****
  • Posts: 908
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: Splotchy shadows wont go away
« Reply #6 on: March 04, 2019, 08:51:27 pm »
Hey Designgestalt.


It is amazing to see your effort you put into this posts.
All thumbs up!


Cheers
Marco

Offline bdesign

  • Hero Member
  • *****
  • Posts: 795
Re: Splotchy shadows wont go away
« Reply #7 on: March 04, 2019, 10:15:32 pm »
Hi Poog-

I realize you can't change your lighting settings at this point, but the main culprit here is the startup.hdr environment. That being said, adding a bit of micro noise bump to the materials will help reduce the splotchiness, but still not perfect. I used a Noise(Texture) node in the Bump channel of both materials, with Scale .1 mm and Bump Height .2. Region renders with and without micro bump attached (each at 256 samples).

Cheers,
Eric
« Last Edit: March 04, 2019, 10:26:23 pm by bdesign »

Offline INNEO_MWo

  • Hero Member
  • *****
  • Posts: 908
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: Splotchy shadows wont go away
« Reply #8 on: March 05, 2019, 12:02:41 am »
That is the reason I love this community.
Dirk and Eric, you're the best.

So Poog.
If you compare the advice of Designgestalt and bdesign (like I did in the attached scene, plus a view things from my perspective) you should finish your renders.

Interesting is, that OnShape is capable to animate deformable meshes. (I have to look into it!)


Have a nice day!

Cheers
Marco

Offline designgestalt

  • Full Member
  • ***
  • Posts: 189
Re: Splotchy shadows wont go away
« Reply #9 on: March 05, 2019, 05:55:41 am »
 thanks Marco,
I guess I can relate very good to the desperation and urge for help, when the deadline is pressing ...
 ;D ;D ;D