Author Topic: keyshot8 animation axis problem  (Read 464 times)

0 Members and 1 Guest are viewing this topic.

Offline PeterSwift

  • Full Member
  • ***
  • Posts: 112
keyshot8 animation axis problem
« on: January 22, 2019, 05:39:02 am »
A new animation project= finding new animation bugs.
Or maybe it's just be that just don't understand the program correctly.

Here a test.

Dark cube has a translation.  Cylinder, has a 360 rotation around the dark cub.
Blue cube is just there to show the original cube position.

I can't make the cylinder follow and rotate around the dark cube. Should be so basic.
« Last Edit: January 22, 2019, 05:41:23 am by PeterSwift »

Offline Esben Oxholm

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 1671
  • esbenoxholm.dk/keyshot-video-course
    • Freelance CG Artist
Re: keyshot8 animation axis problem
« Reply #1 on: January 22, 2019, 06:05:02 am »
Hi Peter.
Have a look at the attached file.

Make sure to nest the cylinder inside the moving cube in the scene tree.

Hope it helps!

Offline PeterSwift

  • Full Member
  • ***
  • Posts: 112
Re: keyshot8 animation axis problem
« Reply #2 on: January 24, 2019, 01:06:37 am »
Yeah I finally made it work.
But there must be some kind of bugs. Becouse now When i try to rotate an object I have been moving around a bit, translations and rotations.   Now when I add a new rotation, so it should rotate around it self (spinn) . I can't make it do it.  It follows some axis somewhere else. It' dont help if i use a new object and select that as an axis.
Very confusing.

Thanks for the help though.