Author Topic: Cannot hide parts with same material  (Read 2824 times)

0 Members and 1 Guest are viewing this topic.

Offline jeffw

  • Full Member
  • ***
  • Posts: 173
Cannot hide parts with same material
« on: September 08, 2011, 08:02:17 am »
I have been asked to produce renderings of an assembly exploded and unexploded view. The renderings need to register perfectly for a rollover so I want them both in the same KS file. I have imported the two models into KS as separate obj files. There are around 50 parts in the assembly. The problem is that since the same parts exist in each assembly need to have the same material I cannot hide just one assembly for a separate render. They both show or neither show. I could make two separate files each with the different assembly  and with the same scene and camera settings but it would be hard to make identical changes to each file should they want changes.

Jeff

guest84672

  • Guest
Re: Cannot hide parts with same material
« Reply #1 on: September 08, 2011, 11:07:52 am »
In the scene tree, right click on the assembly, and select unlink parts. Done.

Offline jeffw

  • Full Member
  • ***
  • Posts: 173
Re: Cannot hide parts with same material
« Reply #2 on: September 09, 2011, 07:05:35 am »
Thanks. That worked to hide the assemblies. It did however make selecting parts on the model with the cursor unreliable. Clicking on a part it would select an adjacent part and the part outline was out of position of the model part. Even with all adjacent parts hidden I could not select the part on wanted on screen. I had to go into the scene tree and keep hiding parts until the one I wanted remained visible. Still I could not select it on the model only on the scene tree. Maybe there is some corruption with this file because I have not noticed this before.

Jeff

guest84672

  • Guest
Re: Cannot hide parts with same material
« Reply #3 on: September 09, 2011, 07:15:27 am »
This sounds strange. You are running KeyShot 2.3, I assume?