Author Topic: Video Output - file, but no video  (Read 1409 times)

0 Members and 1 Guest are viewing this topic.

Offline Crysanth30

  • Newbie
  • *
  • Posts: 3
Video Output - file, but no video
« on: December 28, 2018, 09:50:11 am »
Hey everyone, just started using Keyshot recently. I figured out how to animate my model and tried to render it to a video. I'm not sure what I'm doing wrong - this is the second or third time this has happened. I have it render overnight, computer doesn't sleep while it's running. In the morning I'll have a video in the correct folder, but I can't play it - it has 0 bytes. Why did it run for so long just to give me a blank video file? There are no frame output files, as I did uncheck that.

I'm running this on an Acer TC-780 ( Processor: Intel Core i5-7400 CPU @ 3GHz ), 8GB RAM, Windows 10 64bit operating system. Let me know if I need to provide more information.

Any help is appreciated - Sorry if I don't respond quickly! Thank you!
« Last Edit: December 28, 2018, 09:55:49 am by Crysanth30 »

Offline theAVator

  • Sr. Member
  • ****
  • Posts: 265
  • Acting my shoe size since 1984
Re: Video Output - file, but no video
« Reply #1 on: December 28, 2018, 10:59:55 am »
Sorry to hear that. Can you post what KS version you are using for the support guys.

One suggestion, and you'll likely hear it many more times from users and the Luxion guys, always output frames. If something like this happens, the frames are saved separately and you can use any number of video programs to stitch the sequence together. In fact I'll bet most users are going to suggest only doing frame output and using software to stitch and output whatever format you need. It does save a little front end rendering time if it doesn't have to encode and save the video as part of the rendering process.

For stitching image sequences you can use any number of programs: Premiere and After Effects tend to be the most used, but photoshop can do it, I think VLC can do it, windows movie maker might be able to, etc.

Probably not the answer you want to hear, but might help in the meantime until the Luxion staff is fully staffed after the holidays.
In the meantime, maybe try a different video format besides the MP4, something like an AVI and see if it happens to all formats or if its specific to the MP4 format. It might be a codec issue and might be failing as it encodes.

I also do not know if there are pixel dimension constraints on certain video formats, could try bumping the frame sizes down to more standard def. and see if there is an issue with the size?? I know others have done 4K size renders, but idk if they only do frame outputs and let a higher end program do the processing or if they encode straight in KS.

Offline Crysanth30

  • Newbie
  • *
  • Posts: 3
Re: Video Output - file, but no video
« Reply #2 on: December 28, 2018, 11:31:12 am »
Hi theAVator, thanks for the advice! I'll give what you recommended a shot. I'm running Keyshot 8.1 Pro