Author Topic: [RESOLVED] SolidWorks plugin crashing SolidWorks  (Read 889 times)

0 Members and 1 Guest are viewing this topic.

Offline Speedster

  • Hero Member
  • *****
  • Posts: 2624
[RESOLVED] SolidWorks plugin crashing SolidWorks
« on: December 28, 2018, 10:53:55 am »
Got a problem...

I use SolidWorks 2014 for most of my work, as my clients have not upgraded.

When I installed KeyShot 8.1.59, SolidWorks now crashes with import or update.  I had (have) the SW>KS7 installed, and it worked fine before the new KeyShot update.

I downloaded and installed the SW>KS8 plugin (it sits side-by-side with the KS7 on the tool tray), and it still crashes.  I know the update notice says it's for SW 15 to 19, which I have but don't use, but the 7, which worked before, and 8 plugins both crashes SolidWorks now.

I really depend on the Update feature.

Any clues?

Bill G
« Last Edit: April 17, 2019, 04:03:02 pm by Bruno F »

Offline Ian Reymond

  • Jr. Member
  • **
  • Posts: 52
Re: SolidWorks plugin crashing SolidWorks
« Reply #1 on: March 27, 2019, 02:01:47 pm »
Hello Speedster,

Thank you for your post.
Could you please email us at [email protected] so we can share the latest version of the plugin with you to see if that fixes the issue you are seeing.

Got a problem...

I use SolidWorks 2014 for most of my work, as my clients have not upgraded.

When I installed KeyShot 8.1.59, SolidWorks now crashes with import or update.  I had (have) the SW>KS7 installed, and it worked fine before the new KeyShot update.

I downloaded and installed the SW>KS8 plugin (it sits side-by-side with the KS7 on the tool tray), and it still crashes.  I know the update notice says it's for SW 15 to 19, which I have but don't use, but the 7, which worked before, and 8 plugins both crashes SolidWorks now.

I really depend on the Update feature.

Any clues?

Bill G

Offline Bruno F

  • KeyShot Support
  • Full Member
  • *****
  • Posts: 169
Re: SolidWorks plugin crashing SolidWorks
« Reply #2 on: April 17, 2019, 04:02:20 pm »
SolidWorks crashes when exporting your models via the KeyShot plugin are often the result of unsupported data or errors in the data conversion. Luxion Inc, releases new plugin versions a couple times a year. I suggest staying up to date with the plugins for your KeyShot version.

Download Plugins (Latest Release)
Download Plugins (Older Versions)

If you find that the lastest plugin still fails for you, send us the assembly (and all contained parts) to [email protected] In the meantime, you can import the assembly file or an exported STEP file directly into KeyShot. For details and additional workarounds, click here.

Edit: There have been no replies to this post for more than two weeks, therefore, it has been locked.
If you still need help please open a new post.

Post closed by Luxion Support Team