Author Topic: Rendering Only the Shadows of an Object???  (Read 585 times)

0 Members and 1 Guest are viewing this topic.

Offline easterbunnie228

  • Newbie
  • *
  • Posts: 4
Rendering Only the Shadows of an Object???
« on: December 04, 2018, 08:02:05 am »
Hey guys!

I'm trying to find a way to have my camera or final render pick up the shadows that my wall is casting, WITHOUT showing the wall itself.  I need the wall invisible, but its shadows to still cast.  I'm trying to get a good angle from the same side as the wall but I obviously can't see through the wall without disabling or making it translucent.  I want light to only come through where the windows are on the wall, so I can see the sunlight on objects inside. However, I NEED to make the wall invisible.  Is there any way to do this in Keyshot?

Thanks!

Offline MWo

  • Hero Member
  • *****
  • Posts: 876
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: Rendering Only the Shadows of an Object???
« Reply #1 on: December 04, 2018, 09:53:20 am »
For this reason we can use the ground material. So you can use it on a wall (best way if the wall is thin = surface / no thickness). So an invisible object will catch the shadows but isn’t noticeable if alpha transparency/alpha is checked in the render settings.


Hope that helps


Cheers
Marco


(Written on a mobile)

Offline designgestalt

  • Full Member
  • ***
  • Posts: 179
Re: Rendering Only the Shadows of an Object???
« Reply #2 on: December 04, 2018, 10:38:30 am »
Hello Marco,
I am not sure, if this is, what Easterbunny was asking about.
If I want objects to cast shadows, but I don´t want to see the object, I use the emissive material, turn the intensity to zero and make the material invisible to cameras (little checkbox in the material editor)
however, I am also not sure, if my answer covers your question  ???
cheers
designgestalt

Offline easterbunnie228

  • Newbie
  • *
  • Posts: 4
Re: Rendering Only the Shadows of an Object???
« Reply #3 on: December 04, 2018, 12:02:22 pm »
I'll try both ways and let you know how they turn out for me!  Thanks to you both.

Offline easterbunnie228

  • Newbie
  • *
  • Posts: 4
Re: Rendering Only the Shadows of an Object???
« Reply #4 on: December 04, 2018, 02:38:50 pm »
Update:
Couldn't get either to work the way I wanted to.  The emissive works when I'm working normally in Keyshot but doesn't work when I try to render the camera.  I have tried it with and without the alpha transparency checkbox in the render settings.  The ground material doesn't seem to work either(I'm probably doing something wrong with both of these methods).  It does just about the same thing as the emissive, but isn't invisible to the camera in the normal view.  Yes, I'm checking the alpha transparency checkbox in the render settings using the ground material as well.

EDIT: Also, When doing the emissive I get either a white or black color depending on the strength of the emissive, even when I uncheck visible to camera. For some reason, my part is just turning black when I do what designgestalt said to do.
« Last Edit: December 05, 2018, 09:01:32 am by easterbunnie228 »

Offline PhilipTh

  • KeyShot Support
  • Newbie
  • *****
  • Posts: 20
Re: Rendering Only the Shadows of an Object???
« Reply #5 on: December 06, 2018, 02:10:26 am »
Update:
Couldn't get either to work the way I wanted to.  The emissive works when I'm working normally in Keyshot but doesn't work when I try to render the camera.  I have tried it with and without the alpha transparency checkbox in the render settings.  The ground material doesn't seem to work either(I'm probably doing something wrong with both of these methods).  It does just about the same thing as the emissive, but isn't invisible to the camera in the normal view.  Yes, I'm checking the alpha transparency checkbox in the render settings using the ground material as well.

EDIT: Also, When doing the emissive I get either a white or black color depending on the strength of the emissive, even when I uncheck visible to camera. For some reason, my part is just turning black when I do what designgestalt said to do.

Hello Easterbunnie,

That is weird, from my tests, I could get it to work with the emissive method that designgestalt provided.

Also, if you have "Visible to camera" unselected, it should not be either black or white.

May I ask, what exact version of KeyShot are you using?

Also, what if you try this in a completely empty scene, using only cubes and planes maybe?

Offline designgestalt

  • Full Member
  • ***
  • Posts: 179
Re: Rendering Only the Shadows of an Object???
« Reply #6 on: December 07, 2018, 02:39:07 am »
that seems to be a bug, I had that as well sometimes ...
clicking a few buttons, changing the material back and forth cures it.
normally that method works pretty well, I often have the demand to only render the shadows on an alpha channel.
try it again, I am sure, you will get it to work ...
cheers
designgestalt