Author Topic: Low CPU usage on rendering  (Read 2150 times)

0 Members and 3 Guests are viewing this topic.

Offline djnoone

  • Newbie
  • *
  • Posts: 12
Low CPU usage on rendering
« on: September 14, 2018, 06:39:41 am »
Is it normal my CPU cores to use only 20-30%  when rendering.
Every time.

Offline DriesV

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2387
  • Product Specialist at Luxion
Re: Low CPU usage on rendering
« Reply #1 on: September 14, 2018, 06:47:37 am »
Hi,

Some questions...

Are you stating the CPU utilization, shown on Task Manager (in the case of Windows)?
Is this during real-time rendering?
What kind of scenes are you rendering?

Dries

Offline djnoone

  • Newbie
  • *
  • Posts: 12
Re: Low CPU usage on rendering
« Reply #2 on: September 14, 2018, 07:42:06 am »
Yes, i am talking about windows (10) task manager CPU utilization.

I am rendering mostly bottles (wine - one to five in a scene), nothing heavy.

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1378
Re: Low CPU usage on rendering
« Reply #3 on: September 14, 2018, 08:23:01 am »
How many cores do you have assigned in the KS toolbar? Are you rendering locally? Are you using the Render in Background feature? Any other apps running that would mess this up? I know that when Cinema 4d is running a dymanics simulation even though it only uses one core for those operations it would mess with everything.

Offline djnoone

  • Newbie
  • *
  • Posts: 12
Re: Low CPU usage on rendering
« Reply #4 on: September 14, 2018, 02:14:44 pm »
I am using 3DSmax for modelling, often Keyshot is the only opened software at a time.

The main issue is that i have never been able to make the CPU cores to work on maximum with Keyshot (ver. 6 and 7).
So i am not sure is that is usual behaviour or my machine cannot use whole power for some reason.

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1378
Re: Low CPU usage on rendering
« Reply #5 on: September 17, 2018, 05:53:02 am »
What is this set to?

Offline djnoone

  • Newbie
  • *
  • Posts: 12
Re: Low CPU usage on rendering
« Reply #6 on: September 18, 2018, 11:46:55 am »
"all cores"

Now caught my attention, that (from another post) there was a suggestion to use Process Lasso  - and in this application CPU is visualized as 100% in use and on windows task manager stays on 30%

Offline rorroz2

  • Newbie
  • *
  • Posts: 4
Re: Low CPU usage on rendering
« Reply #7 on: October 02, 2018, 05:57:33 am »
This often Happens when you CPU is thermal throttling.

Keyshot will read as 100% in the software but task manger will show lower cpu usage as your process begins to under-clock to keep below its thermal ceiling.

Try checking your CPU temperatures using Core Temp https://www.alcpu.com/CoreTemp/ or something like that whilst rendering and report back.  Also send a screenshot of the CPU section of the Task managers Performance Tab whilst you are doing a render.

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 747
  • David Merz the Third
    • MerzTheThird
Re: Low CPU usage on rendering
« Reply #8 on: October 02, 2018, 08:46:25 am »
Hmm interesting thread!

Also, a good practice (if possible) is to not set the Keyshot rendering to 100% of your CPU, it leaves little room for any other of the small processes your machine might need from time to time and leads to more lockups. This of course, has been my experience. I usually keep mine as the next lowest setting. In my case, 92%.




Offline djnoone

  • Newbie
  • *
  • Posts: 12
Re: Low CPU usage on rendering
« Reply #9 on: October 02, 2018, 11:18:50 am »
Try checking your CPU temperatures using Core Temp https://www.alcpu.com/CoreTemp/ or something like that whilst rendering and report back.  Also send a screenshot of the CPU section of the Task managers Performance Tab whilst you are doing a render.


Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1378
Re: Low CPU usage on rendering
« Reply #10 on: October 02, 2018, 12:09:16 pm »
That right there is thermal throttling, so that is why you are seeing the slowdowns. I had a problem with my home workstation with this initially. Turns out the cooler wasn't seated properly on the CPU surface. Once I got it set properly performance went up, but I'm very greatful that the chip throttled itself instead of burning up.

Offline djnoone

  • Newbie
  • *
  • Posts: 12
Re: Low CPU usage on rendering
« Reply #11 on: October 02, 2018, 12:45:28 pm »
I do not understand a word you have said =)
What i am supposed to do in this case?

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 747
  • David Merz the Third
    • MerzTheThird
Re: Low CPU usage on rendering
« Reply #12 on: October 02, 2018, 12:48:02 pm »
100 degrees celcius!

What he is saying is your CPU is running HOT. So what your computer does to combat how hot it is getting, is it slows down its performance (throttling).

Do you have a cooler on your CPU? Heatsink? (Something that sits on top of your CPU and draws heat away from it to keep it running cooler.

If you do, you might have one that is malfunctioning and either need to replace the part or it could be incorrectly installed.
If you resolve this heating issue, you will stop the throttling, and you will see your CPU perform to its full potential.

EDIT. Just so you know, your i7 CPU should be running no hotter than 60 to 65 degrees celcius for extended periods of time.
« Last Edit: October 02, 2018, 12:49:33 pm by DMerz III »

Offline djnoone

  • Newbie
  • *
  • Posts: 12
Re: Low CPU usage on rendering
« Reply #13 on: October 03, 2018, 10:36:39 am »
Not to be ahead of myself, but FOR NOW - after dust cleaning (of the fan) and driver update things dramatically changed:

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 747
  • David Merz the Third
    • MerzTheThird
Re: Low CPU usage on rendering
« Reply #14 on: October 03, 2018, 11:17:16 am »
That's looking more appropriate