Author Topic: To Luxion in particular: Slave tray weirdness...  (Read 771 times)

0 Members and 1 Guest are viewing this topic.

Offline Nobolut

  • Newbie
  • *
  • Posts: 2
To Luxion in particular: Slave tray weirdness...
« on: August 10, 2018, 12:02:47 am »
Hey there,

I work in an environment where we have a small renderfarm and sometimes I add my pc as a slave to help.
What I find very unpractical is that when I'm working on something else and need to keep my cores for me, I quit the Network Rendering Queue and in the Windows task bar lower right (near the clock), I right click on the Network Slave Tray and select "Quit".

The problem is that although the icon disappear from the task bar,  it's still running in background. So I need to open the Windows Task Manager, log as an admin, then I need to right click on the keyshot_network_slave_watchdog.exe and select "End Process". Then I need to do the same for keyshot_network_slave.exe. If I don't shut the watchdog first and shut only the keyshot_network_slave.exe, the watchdog make it restart after a few seconds. This is really annoying because sometimes I forget the shut the damn process when I arrive at work the morning and suddenly, the performance of my computer just freefalls to zero when someone elsewhere submits a job on the Network Queue. (And sometimes it makes my other programs crash or get unresponsive which drives me crazy/wacko/black-angry).

So I need two things:

1. that Slave Tray doesn't start automatically when I switch my computer on.
2. that the Slave Tray process gets completely switched off when I quit the Network Queue.

Is that possible Luxion?

Thanks!

Offline Morten Kristensen

  • root
  • Administrator
  • Full Member
  • *****
  • Posts: 128
  • Software Engineer, Luxion
Re: To Luxion in particular: Slave tray weirdness...
« Reply #1 on: August 23, 2018, 12:25:01 am »
Hello Philippe,

I'm sorry you're having inconveniences. When you run a NR slave via the NR configurator then it is started as a service in the background - not related to UI. The NR slave tray connects locally to the slave when it is running to communicate changes to allowed number of cores it can use. But when it is closed the slave keeps running.

The reason you see the NR slave restarted after closing it, is because that's the job of the service watchdog.
If you want to stop the slave then the easiest way is to do it via the configurator's "Service Status" panel and click the "Stop" button.

The slave tray only starts because it's the default in settings. To disable this behavior, open the configurator, go to the "Slave" panel, and untick the "Launch Slave Tray on user login" check box. Then close and remember to save settings and possibly restart services if you so require.

Additionally, I would like to mention that we have slave scheduling support via the monitor (queue) in the "Slave Status" area. There you can define when slaves are allowed to be active and when not to be active. Note that your user account will need to have the "Manage slave schedule" privilege or simply have an admin account.

I hope this helps.
Thanks!