Author Topic: Low quality on my shadows (shadow quality = 5)  (Read 4155 times)

0 Members and 1 Guest are viewing this topic.

Offline zooropa

  • Sr. Member
  • ****
  • Posts: 377
Low quality on my shadows (shadow quality = 5)
« on: August 06, 2018, 08:36:44 am »
Hi,

I am dealing with a poor shadow quality. For first time I am trying to use the shadow "catcher" that comes in KS. Meaning not using any surface for my floor. Even cranking shadow quality to 5, still get a non blended effect.

Please find attached the image,

Thanks a lot.

Offline bdesign

  • Hero Member
  • *****
  • Posts: 795
Re: Low quality on my shadows (shadow quality = 5)
« Reply #1 on: August 06, 2018, 08:44:51 am »
Hi zooropa-

Try increasing the Ground Size under the Environment tab, to at least half the size of the environment.

Cheers,
Eric

Offline zooropa

  • Sr. Member
  • ****
  • Posts: 377
Re: Low quality on my shadows (shadow quality = 5)
« Reply #2 on: August 06, 2018, 02:44:02 pm »
I am afraid is not working. Just in case Did you mean the parameters highlighted ?


Offline Will Gibbons

  • Hero Member
  • *****
  • Posts: 2849
  • willgibbons.com
    • My Website
Re: Low quality on my shadows (shadow quality = 5)
« Reply #3 on: August 06, 2018, 04:19:59 pm »
How many samples are you rendering to?

Offline MWo

  • Hero Member
  • *****
  • Posts: 880
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: Low quality on my shadows (shadow quality = 5)
« Reply #4 on: August 06, 2018, 10:49:06 pm »
Hello zooropa.

As far as I can see, you can try to render out an 32 bit image and convert it to 8bit via Photoshop using normalize histogram option.

And you can uncheck the glatten grounds option.

The advanced control render Moder allows shadow quality up to 10. If you think this would bring better renderings.


Hope that helps

Cheers
Marco

Offline zooropa

  • Sr. Member
  • ****
  • Posts: 377
Re: Low quality on my shadows (shadow quality = 5)
« Reply #5 on: August 06, 2018, 11:22:37 pm »
How many samples are you rendering to?

tried from 250 to 500

Offline zooropa

  • Sr. Member
  • ****
  • Posts: 377
Re: Low quality on my shadows (shadow quality = 5)
« Reply #6 on: August 06, 2018, 11:25:52 pm »
Hello zooropa.

As far as I can see, you can try to render out an 32 bit image and convert it to 8bit via Photoshop using normalize histogram option.

And you can uncheck the glatten grounds option.

The advanced control render Moder allows shadow quality up to 10. If you think this would bring better renderings.


Hope that helps

Cheers
Marco

Thanks Marco!

Its a 32 bit image.

Will try  unchecking flatten ground.

Regarding shadow quality I do not understand why 5 is not enough. Its quite a simple scene. It might be easier to use a physical ground and just mask the camera no? What do you think ?

Thanks

Offline MWo

  • Hero Member
  • *****
  • Posts: 880
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: Low quality on my shadows (shadow quality = 5)
« Reply #7 on: August 07, 2018, 12:43:32 am »
Quality 5 for this scene should be enough or a bit too high?!
I have to test it.
Any chance to share this scene? Perhaps with a dummy object?!

Cheers
Marco

Offline zooropa

  • Sr. Member
  • ****
  • Posts: 377
Re: Low quality on my shadows (shadow quality = 5)
« Reply #8 on: August 07, 2018, 12:50:29 am »
Hello zooropa.

As far as I can see, you can try to render out an 32 bit image and convert it to 8bit via Photoshop using normalize histogram option.

And you can uncheck the glatten grounds option.

The advanced control render Moder allows shadow quality up to 10. If you think this would bring better renderings.


Hope that helps

Cheers
Marco

Its not flatten ground :(

Offline MWo

  • Hero Member
  • *****
  • Posts: 880
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: Low quality on my shadows (shadow quality = 5)
« Reply #9 on: August 07, 2018, 02:01:29 am »
Can your share:
- this scene?
- a Screenshot of the lighting or render ?

Offline zooropa

  • Sr. Member
  • ****
  • Posts: 377
Re: Low quality on my shadows (shadow quality = 5)
« Reply #10 on: August 07, 2018, 02:05:53 am »
I made a test with a surface instead of using the environment > ground shadows

I am quite surprised. Not only the quality of the shadows were significantly better (got rid of the weird stripes). The FPS doubled with a ground. My question that comes from this experience:

What would be the reason for the future of the ground shadows. I am not challenging KS at all, not criticising either. I am trying to understand if I am missing something. I notice that when I load it in PS the camera comes without the background, but shadows. Which is super nice. Isn't this also possible with rendering the layer of my group? mmm

Now the problem is "solve", but still interested in your thoughts about when to use the environment features ?

Btw I checked in online manual ...it says "keyshot 8" mmm?

Thanks 

Offline zooropa

  • Sr. Member
  • ****
  • Posts: 377
Re: Low quality on my shadows (shadow quality = 5)
« Reply #11 on: August 07, 2018, 02:06:25 am »
Can your share:
- this scene?
- a Screenshot of the lighting or render ?

yes! can I send it to your email ?

Offline zooropa

  • Sr. Member
  • ****
  • Posts: 377
Re: Low quality on my shadows (shadow quality = 5)
« Reply #12 on: August 07, 2018, 03:50:03 am »
My bad, plane under my object did not solve my shadow problem....:(

Offline bdesign

  • Hero Member
  • *****
  • Posts: 795
Re: Low quality on my shadows (shadow quality = 5)
« Reply #13 on: August 07, 2018, 09:13:20 am »
Is the gradient banding in the shadows visible before changing down from 32 bit mode? Perhaps try first switching to 16 bit mode and adding a bit of noise to the background before downing to 8 bit. Does that help with the banding? What about saving the final image out as a better format than JPEG, such as a lossless TIFF or PNG? If you attach the KSP to your post I'll take a look as well.

Cheers,
Eric
« Last Edit: August 07, 2018, 09:18:10 am by bdesign »

Offline MWo

  • Hero Member
  • *****
  • Posts: 880
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: Low quality on my shadows (shadow quality = 5)
« Reply #14 on: August 07, 2018, 09:39:48 am »
My bad, plane under my object did not solve my shadow problem....:(

No problem.
Just

[email protected]
(Currently you’ll receive an “out of office reply”)