Author Topic: "Cannot save multi material "[MATERIAL]" within multi material...(ignoring)"  (Read 852 times)

0 Members and 1 Guest are viewing this topic.

Offline philkang

  • Newbie
  • *
  • Posts: 1
Windows 10 Pro 1803
KeyShot 7.3 Pro
No Plugin
3ds Max 2019

I can't save my bip file. The original bip file originated from the same computer but I had to reformat the system. When I reinstalled KeyShot, the files were fine, would save but would produce warnings due to missing materials and labels.

The warnings originally stemmed from a directory issue. When I re-installed windows I had a slightly different username. To remedy this solution I dug around for a way to redirect labels & materials and things like that.

Originally tried to correct the user directory to the original but could not because of various services already in the computer. Ended up re-downloading all materials and importing all labels.

Everything seemed fine for a few weeks but out of the blue I keep getting a multitude of the same error in red for various versions of the same multi material:

"(XX:XX:XX) Cannot save multi material "[MATERIAL]" within multi material "[MATERIAL]" (ignoring)"

My question is, I went ahead and removed all instances of this multi material on the file. That didn't seem to work so I went ahead and toggled off all multi materials as well. Does anyone have a fix for this issue?

Offline RTLabs

  • Newbie
  • *
  • Posts: 1
Mac O.S. 10.10
Keyshot Pro 7.3.40
No plugins
Bip files (worked fine last week)

I have similar problem today.
I open a bip file without any problem (all the materials are correctly loaded). But when I save it, I receive an error message for all the multi-materials: "(XX:XX:XX) Cannot save multi material "[MATERIAL]" within multi material "[MATERIAL]" (ignoring)".
And if I re-open the saved version with errors, the materials are missing...

Offline Rex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 781
This issue has been fixed in KeyShot 8. You will have to recreate the Multi-Material.

Sorry for the trouble.

Offline Caspian

  • Newbie
  • *
  • Posts: 4
Hi Rex,

I'm getting the same error on a file created in KeyShot 8.1. Same error on Mac and Windows.

Any workaround for this?

Thanks,

LeeD

This issue has been fixed in KeyShot 8. You will have to recreate the Multi-Material.

Sorry for the trouble.

Offline PhilipTh

  • KeyShot Support
  • Newbie
  • *****
  • Posts: 20
Hello Caspian,

The workaround would be to actually disable the multi-materials on the material causing the issue.

If you have done this, and it still is causing issues, feel free to send your scene over to us at support@luxion.com