Author Topic: The leaves look transparent  (Read 1026 times)

0 Members and 1 Guest are viewing this topic.

Offline Zvi

  • Full Member
  • ***
  • Posts: 242
The leaves look transparent
« on: May 31, 2018, 11:41:52 am »
The tree model uses a billboard for the leaves. Why do they look transparent?

Offline bdesign

  • Hero Member
  • *****
  • Posts: 795
Re: The leaves look transparent
« Reply #1 on: May 31, 2018, 12:36:31 pm »
Because you have the Opacity mapped with the same texture as the Diffuse. You need an b&w alpha map (white silhouette on black background).

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1429
Re: The leaves look transparent
« Reply #2 on: May 31, 2018, 01:00:05 pm »
And if the image texture has an alpha built in already, you shouldn't even need the opacity map to cut the leaves out, just one to control some little tiny bit of transparency if you wanted to.

Offline Zvi

  • Full Member
  • ***
  • Posts: 242
Re: The leaves look transparent
« Reply #3 on: May 31, 2018, 01:30:14 pm »
Because you have the Opacity mapped with the same texture as the Diffuse. You need an b&w alpha map (white silhouette on black background).
I did as you said with a tiff file, but the leaves became black, although I used a translucent material.

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 810
  • David Merz the Third
    • MerzTheThird
Re: The leaves look transparent
« Reply #4 on: May 31, 2018, 01:30:24 pm »
You can change the mapping opacity mode to Alpha instead of color if you want to read only the alpha channel of the map. That will disregard the color information. (look under opacity map settings near the top)

Offline bdesign

  • Hero Member
  • *****
  • Posts: 795
Re: The leaves look transparent
« Reply #5 on: May 31, 2018, 01:45:19 pm »
The issue with your TIFF file is that it is reversed: the leaf needs to be white, on a black background.

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 810
  • David Merz the Third
    • MerzTheThird
Re: The leaves look transparent
« Reply #6 on: May 31, 2018, 02:01:34 pm »
 :) there's also "inverse color" mapping mode if you did have a black (yes) and white (no) alpha. But technically, Eric is correct, they need to be flipped.

I prefer to use Alpha Mapping mode if I have transparency in my .png or .tif, I find it to be more reliable and one less map to load in my file if I want to double purpose my diffuse map.

Offline Zvi

  • Full Member
  • ***
  • Posts: 242
Re: The leaves look transparent
« Reply #7 on: May 31, 2018, 02:15:07 pm »
The issue with your TIFF file is that it is reversed: the leaf needs to be white, on a black background.
Can you show me where is it exactly the opacity map settings?

Offline Zvi

  • Full Member
  • ***
  • Posts: 242
Re: The leaves look transparent
« Reply #8 on: May 31, 2018, 02:32:59 pm »
:) there's also "inverse color" mapping mode if you did have a black (yes) and white (no) alpha. But technically, Eric is correct, they need to be flipped.

I prefer to use Alpha Mapping mode if I have transparency in my .png or .tif, I find it to be more reliable and one less map to load in my file if I want to double purpose my diffuse map.
I did as your advice, but the leaves became transparent

Offline Zvi

  • Full Member
  • ***
  • Posts: 242
Re: The leaves look transparent
« Reply #9 on: May 31, 2018, 03:35:19 pm »
The issue with your TIFF file is that it is reversed: the leaf needs to be white, on a black background.
Thanks a lot! I found it, and it really solved the problem. By the way, I used for it the original image.

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 810
  • David Merz the Third
    • MerzTheThird
Re: The leaves look transparent
« Reply #10 on: June 01, 2018, 08:51:29 am »
 :) Glad  you figured it out! I was going to suggest clicking on your opacity channel so we can see the settings there, you had the diffuse channel selected so we couldn't see the Opacity Mapping Mode in your screenshot.