Author Topic: Deformable meshes - problem with .abc file geometry / [Blender/Keyshot]  (Read 4668 times)

0 Members and 1 Guest are viewing this topic.

Offline Oskar_K

  • Newbie
  • *
  • Posts: 12
Re: Deformable meshes - problem with .abc file geometry / [Blender/Keyshot]
« Reply #15 on: February 21, 2018, 03:01:32 pm »
Hello everyone,

It seems that the problem is solved! After dozens of hours spent trying normals modifers, triangulation and checking/unchecking random checkboxs inside Blender I got the solution !

Just for making life of future keyshot users' generations easier, here's what helped:
1. for multiple objects: simply unchecking "NORMALS" checkbox while exporting alembic files from Blender
2. for deformations:  simply unchecking "NORMALS" checkbox while exporting alembic files from Blender AND unchecking "CALCULATE NORMALS" while importing abc file into Keyshot

!!! :)

Please find attached simple simulation and bending animation, both animated in Blender and rendered in Keyshot.

Oskar
« Last Edit: February 21, 2018, 03:03:59 pm by Oskar_K »

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 825
  • David Merz the Third
    • MerzTheThird
Re: Deformable meshes - problem with .abc file geometry / [Blender/Keyshot]
« Reply #16 on: February 22, 2018, 07:50:24 am »
 :) Hey that's very nice of you to come back with the solution, very much appreciated! Glad you got it to work, I'm sure I would try deformations sometime in the near future, and you probably just saved me tons of headaches.

Offline Chad Holton

  • Hero Member
  • *****
  • Posts: 1389
    • Portfolio
Re: Deformable meshes - problem with .abc file geometry / [Blender/Keyshot]
« Reply #17 on: February 22, 2018, 04:14:35 pm »
Nice! I've been wanting to test this out with Blender too. Thanks for the tips.

Offline Will Gibbons

  • Hero Member
  • *****
  • Posts: 2849
  • willgibbons.com
    • My Website
Re: Deformable meshes - problem with .abc file geometry / [Blender/Keyshot]
« Reply #18 on: March 06, 2018, 08:25:02 am »
+1

I haven't had time to troubleshoot all the possible options. Thanks for sharing your findings here.