Author Topic: Fade animation - black spots problem  (Read 2349 times)

0 Members and 1 Guest are viewing this topic.

Offline VertexBee

  • Newbie
  • *
  • Posts: 5
    • Portfolio
Fade animation - black spots problem
« on: January 15, 2018, 02:18:52 pm »
Hello!

I'm new to the forum and new to using Keyshot.

I've this problem with weird black areas showing while parts are fading, but not fully transparent.
Once the part disappear completely the materials show up correctly.

Attached is a gif showing the problem - see how the flat orange surfaces have black spots while the parts fade one by one.

The above model is sliced several times into several separate parts. I've animated the transparency effect by using the animation - fade feature.

Does somebody have a clue what is causing this and how to fix it?
Thanks!



Offline DriesV

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2425
  • Product Specialist at Luxion
Re: Fade animation - black spots problem
« Reply #1 on: January 16, 2018, 03:44:37 am »
Difficult to tell what is going on here.

Any chance you can share the KeyShot scene? You can upload here (or link to it) or send to keyshot.wetransfer.com (dries-at-luxion-dot-com).

Dries

Offline VertexBee

  • Newbie
  • *
  • Posts: 5
    • Portfolio
Re: Fade animation - black spots problem
« Reply #2 on: January 16, 2018, 05:56:16 am »
Hi

I've just send the scene to keyshot.wetransfer.com, but the recipient e-mail was [email protected]

Thank you so much for taking the time to look up this! Much appreciated!

Martin

Offline DriesV

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2425
  • Product Specialist at Luxion
Re: Fade animation - black spots problem
« Reply #3 on: January 16, 2018, 07:18:33 am »
You can change [email protected] to another email address. :)
I don't have direct access to it now.

Perhaps you can send me the WeTransfer link through PM?

Dries

Offline VertexBee

  • Newbie
  • *
  • Posts: 5
    • Portfolio
Re: Fade animation - black spots problem
« Reply #4 on: January 16, 2018, 08:16:05 am »
Sorry about that, hope you will receive it this time, I've used the other e-mail. :)

Offline theAVator

  • Sr. Member
  • ****
  • Posts: 264
  • Acting my shoe size since 1984
Re: Fade animation - black spots problem
« Reply #5 on: January 16, 2018, 09:55:16 am »
Keep an eye out for any overlapping geometry. They will turn black like that when fading. I commonly get that in my models and if I need to something with it - i.e. its too obvious or important, I just nudge the part a little bit with the translation values or the move tool. 

If that doesn't happen to be the case in this instance, then just ignore what I said. lol
But I do get it where overlapping geometry causes black areas in a fade animation.

Offline VertexBee

  • Newbie
  • *
  • Posts: 5
    • Portfolio
Re: Fade animation - black spots problem
« Reply #6 on: January 16, 2018, 11:02:22 am »
Keep an eye out for any overlapping geometry. They will turn black like that when fading...

This was helpful! Offseting the parts slightly apart from each other so they don't touch their surfaces fixed the problem.
Thanks a lot!