Author Topic: Fade in the middle of animation problem  (Read 1193 times)

0 Members and 1 Guest are viewing this topic.

Offline Arian Shamil

  • Hero Member
  • *****
  • Posts: 656
  • -Ariandesign-
    • my site
Fade in the middle of animation problem
« on: January 03, 2018, 11:06:43 am »
Hi,
I've already watched this thread...but it doesn't worked to me... https://www.keyshot.com/forum/index.php?topic=12790.msg70496#msg70496

My problem is that I've an object that must be hide untile sec 3 and then start to fade just from second number 3.....

If i apply, at the beginning, a 0-0 fade from sec 0 to sec 3...the secondary fading, from sec 3 to sec 5 (fade 0-100) doesn't work....
It work only if i remove the fade 0-0 before its....with the result that the object is visible....

And the problem is that I've to combine 21 objects fading.....sequential fading so I can't render separate animations....

Offline theAVator

  • Full Member
  • ***
  • Posts: 248
  • Acting my shoe size since 1984
Re: Fade in the middle of animation problem
« Reply #1 on: January 03, 2018, 11:19:20 am »
On your initial fade to hide the object, try a 100-0 fade instead of the 0-0 fade. See if that produces the correct result.

if it works, worst case you may have to bump your times a lil to compensate. When I'm doing something like this, I always start with everything visible, run a 100-0 hide on everything and then I just ditch the first frames where this happens on the post prod. side of things.

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1448
Re: Fade in the middle of animation problem
« Reply #2 on: January 03, 2018, 12:08:43 pm »
Yep, this is what has to happen sometimes as well. While its not what you'd expect and want, its a workaround that gets you moving.

Then head over to the bigs/wish list thread and leave a comment about it there. The mods and developers are remarkably responsive to this sort of thing. Dries and Will are always looking at those and might have a solution as well.

Offline Arian Shamil

  • Hero Member
  • *****
  • Posts: 656
  • -Ariandesign-
    • my site
Re: Fade in the middle of animation problem
« Reply #3 on: January 03, 2018, 02:33:30 pm »
Thank you guys!
To both of you...
I'll try to find a solution...
;)