Author Topic: Split Surfaces on Rhinoceros Import  (Read 931 times)

0 Members and 1 Guest are viewing this topic.

Offline NM-92

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 1088
    • Behance
Split Surfaces on Rhinoceros Import
« on: October 25, 2017, 02:06:48 pm »
Hey there. Don't know if this is a bug or just the normal behaviour with Rhino files, but when i import my models on KS7, every single surface is split. The scene tree still is grouped by parts, but inside each one there are a TON of single surfaces. Of course, this doesn't let me select parts on the viewport, so i have to select a whole part directly on the scene tree.

Any solutions for this ? Maybe i'm missing something ?

Offline Will Gibbons

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2558
  • Training Specialist at Luxion
    • KeyShot Training
Re: Split Surfaces on Rhinoceros Import
« Reply #1 on: October 26, 2017, 01:09:16 am »
I have run into this with Rhino files. I'm not a user of Rhino, so I can't say for sure... other than I've seen this and never had similar experiences with SolidWorks.

Offline DriesV

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2347
  • Product Specialist at Luxion
Re: Split Surfaces on Rhinoceros Import
« Reply #2 on: October 26, 2017, 04:51:45 am »
Hey Nico,

There is indeed an issue with merging faces for Rhino model imports in 7.1.51.
There are two ways to get "stitched" parts for Rhino models:
  • Import with option 'Import NURBS Data' checked
  • Use the Rhino plugin to transfer models to KeyShot

The import issue will be fixed in 7.2.

Dries

Offline NM-92

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 1088
    • Behance
Re: Split Surfaces on Rhinoceros Import
« Reply #3 on: October 26, 2017, 05:57:48 am »
Cool. It's not a major inconvenience though it's a bit annoying :P Thanks for the info Dries.