Author Topic: BIP import freezing  (Read 1105 times)

0 Members and 1 Guest are viewing this topic.

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1474
BIP import freezing
« on: August 31, 2017, 11:27:12 am »
I have a template project set up in KS 7.0.465, and I have 2 cameras that are used for product views. Old practice is to duplicate an old project, delete the product, import the new product that is already set up in its own bip file. Did it lots in KS6 (and other version of KS7 I think) but now that workflow freezes right away at the "Preparing Geometry". I can cancel the import, but when I do KS actually locks up and I have to force quit. Attached are screen shots of the import settings and the error. There are two ksp files, #1 open first, and #2 to import into #1.

zip file with ksp files was sent to support@ via wetransfer

Running KS7.0.456
Windows 7 professional SP1(from 2009 for crying out loud)
HP640 12c24t
32 gb ram
NVIDIA GTX980
Logitech K750 keyboard
Logitech MX Master mouse
Samsung junk business class monitors





Offline MWo

  • Hero Member
  • *****
  • Posts: 836
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: BIP import freezing
« Reply #1 on: September 03, 2017, 09:54:07 pm »
In first step I would try to import with unchecked material options. Why should KeyShot retain the materials and assign the new library materials.

So what the import does without any option?

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1474
Re: BIP import freezing
« Reply #2 on: September 25, 2017, 08:18:29 am »
I am assuming that keeping those options checked would a) import and use the materials used in the original bip file, keeping all labels, colors, textures in place and brought into the current project and b) make those materials available in the library for use on other models in the project. I see no reason why this shouldn't be the case, but you are correct in that if I uncheck everything the model is brought in with all materials in tact, and labels in place. So I'm not sure why those options are there for bip files if the default behavior brings everything in anyway (which is the expected behavior)