Author Topic: Unwanted Light edges around my models  (Read 2794 times)

0 Members and 1 Guest are viewing this topic.

Offline Oblotzky

  • Newbie
  • *
  • Posts: 5
Unwanted Light edges around my models
« on: July 25, 2017, 11:34:18 pm »
Hello,

I use KeyShot to render keysets that I like to design in my spare time. For presenting them, I wish to render them on a transparent background so they can be incorporated on websites easily. However, I have a little issue with lighting. Only when I enable Ground Shadows will I achieve nice and evenly lit keys, but that brings shadows with it on the transparent background that I don't want. When I disable ground shadows, the outer edge of the keys is overlit.

Ground Shadows enabled



Ground Shadows disabled


The images posted here are of course not transparent, I added a black background to highlight the issue. It's not noticeable when used on a light website like this forum, but my project pages usually have a dark style where it stands out more prominent.

Flatten Ground is enabled in both cases, it did help a bit. Any ideas would be very appreciated!

Offline richardfunnell

  • Sr. Member
  • ****
  • Posts: 392
  • ID Rendering
    • My page
Re: Unwanted Light edges around my models
« Reply #1 on: July 26, 2017, 06:05:35 am »
How does it look if you change your Ground Shadow color to white?

Also, if you have KeyShot Pro you can isolate geometry to a Render Layer for easy selection within Photoshop. You could render the keys to a separate layer (with transparency) and simply save that as your output.

Offline Oblotzky

  • Newbie
  • *
  • Posts: 5
Re: Unwanted Light edges around my models
« Reply #2 on: July 26, 2017, 10:20:16 am »
How does it look if you change your Ground Shadow color to white?

Also, if you have KeyShot Pro you can isolate geometry to a Render Layer for easy selection within Photoshop. You could render the keys to a separate layer (with transparency) and simply save that as your output.

With white shadows, it looks like the undesired result. But also, my goal here is to use no shadows at all.

Unfortunately I only have the HD version  :(

Offline Esben Oxholm

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 1670
  • esbenoxholm.dk/keyshot-video-course
    • Freelance CG Artist
Re: Unwanted Light edges around my models
« Reply #3 on: July 26, 2017, 10:30:22 pm »
For a workaround you could maybe place the keys on a plane with the 'flat' material type applied and making it completely black.
Then render it out and use the magic wand tool to select the background and delete it.

It might work.
Hope it helps.

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 825
  • David Merz the Third
    • MerzTheThird
Re: Unwanted Light edges around my models
« Reply #4 on: July 27, 2017, 08:52:51 am »
Esben mention the solution I would go with.
It does require PS or another image editing software, but it looks like you have that covered. The texturing in this image is beautiful!

Offline Will Gibbons

  • Hero Member
  • *****
  • Posts: 2849
  • willgibbons.com
    • My Website
Re: Unwanted Light edges around my models
« Reply #5 on: July 28, 2017, 07:40:46 am »
Another option is to use a ground plane and sink the keys slightly below it. Set the ground plane to a flat black material, then magic-wand the black in PS and delete it.