Author Topic: Specific sizing for box map projection in textures instead of just "Scale"?  (Read 2335 times)

0 Members and 1 Guest are viewing this topic.

Offline Renata

  • Newbie
  • *
  • Posts: 11
Hi everyone,
So i have another problem,  is there a way to input specific sizing for the box mapping in textures? i need it to be accurate so scaling alone is not enough.
i have real world textures that i need to project accurately.

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 824
  • David Merz the Third
    • MerzTheThird
The only solve I can think of would be to create your 'label' or map to be the known dimension you need it to be. For instance, a label that is 5 by 5 inches in Adobe Illustrator/Photoshop. Take note of the dpi of the image, like 300dpi or 600dpi (which is the minimum I usually go). And check that box in Keyshot that says DPI and input the correct #. Assuming your model and your units are correct, this should correlate to an accurate sized map in Keyshot. Hope that makes sense?

I know there are some older webinars and quick tips that talk about this on the Keyshot main website.

Offline Renata

  • Newbie
  • *
  • Posts: 11
Yes makes perfect sense, but for some reason it is not working out for me.
 i can't put my finger on the problem. so i set the scene units to cm imported my model in cm (a 7.7x7.7 cm plane) applied my 7.7x7.7cm texture map , enabled DPI and entered the resolution value i checked in Photoshop 527.953 pixel/cm but it is still not working out .
Notice in the first attached image the texture map doesn't even show until i increase the scale and even at 100 the image scale is not right .
in the second image to the right  the size keyshot gives us for that plane is shown and it is 0.077x0.077 cm .
I also attached the file ...
Thank you for helping me out i appreciate it

Offline Søren

  • Developer
  • Jr. Member
  • *****
  • Posts: 81
  • KeyShot Developer
    • KeyShot
Please note that dpi is "pixels per inch" (not cm). Also verify object size matches your expectations (see size under object properties under the scene tree).

In KeyShot 7 you can specify the size of the texture directly (e.g. in cm).

Søren

Offline Renata

  • Newbie
  • *
  • Posts: 11
ok so i set my scene units to "Inches" and i entered the dpi "pixel per inch" but i still had to scale it by 0.01 it doesn't fit perfectly but will have to do for now.
so my only option to use the dpi (in order to have accurate texture dimensions) is to set the scene unit to inches and enter the dpi in inches? 

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 824
  • David Merz the Third
    • MerzTheThird
You shouldn't have to change your keyshot scene units. But your image in photoshop should be to scale. (meaning, if your label is 50 cm tall, it should be 50 inches tall in photoshop regardless of the DPI.) DPI is just a way to translate how dense the pixel count is within an inch squared. I am on a non-Keyshot machine at the moment or else I'd take a look. Sorry you're having these issues, sounds like a hassle.

Offline Søren

  • Developer
  • Jr. Member
  • *****
  • Posts: 81
  • KeyShot Developer
    • KeyShot
I had a look at your ksp, and I can see that the plane itself is not 7.7 cm x 7.7 cm, but rather 0.0770 cm x 0.0801 cm - a factor 100 too small. Something went wrong during your import when assigning units, but also something else since the plane is not perfectly square.

In addition, DPI means needs to be specified in pixels/inch regardless of whatever unit you have chosen in KeyShot. The texture you attached has a DPI of 1341 px/in (which is the same as the the 528 px/cm you specified but in a different unit). It _has_ to be px/in.

I tried setting the units correctly in your scene - this is very important, reset the mapping (big reset button on the texture property page) and entered 1341 in the DPI checkbox and the texture fit nicely (although since the plane was then 7.7cm x 8.01 cm there was obviously a gap).

Søren