Author Topic: mapping dont match  (Read 3930 times)

0 Members and 1 Guest are viewing this topic.

Offline Tak

  • Newbie
  • *
  • Posts: 6
mapping dont match
« on: May 22, 2017, 08:58:48 pm »
hi im new to the program and trying to get seamless images on my project.
Theres this separation line Im having trouble with and im not sure if this causing this but the images on both side dont match or face different direction.

like Case A and B, they catch the same separation line so i thought theres something wrong with my modeling.
but like Case C and D, they don catch the line but they face different direction..
please help..

Im using Keyshot 6 and Rhino 5 for modeling.
its a one single closed polysurface / solid part.

Tak
« Last Edit: May 23, 2017, 12:08:37 am by Tak »

Offline MWo

  • Hero Member
  • *****
  • Posts: 878
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: mapping dont match
« Reply #1 on: May 23, 2017, 09:48:57 am »
Can you share your test files as map? I'm sure many users can help solving this!

Offline Tak

  • Newbie
  • *
  • Posts: 6
Re: mapping dont match
« Reply #2 on: May 23, 2017, 05:49:00 pm »
Hi MWo,
I upload the step file and image files that I used for mapping here.
The wood comes from Keyshot itself and the checker is made by me on illustrator.
hope this helps to solve this issue..

Offline MWo

  • Hero Member
  • *****
  • Posts: 878
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: mapping dont match
« Reply #3 on: May 24, 2017, 08:58:43 am »
So, I played with your file.


First thing: the step file (in your zip file) seems to break the UV coordinates. Maybe the plugin "Rhino to KeyShot" would help?!
I used the cylindrical mapping option and moved the border to the small open gap.


All details can be seen in the attached ksp file.


Hope that helps.


Cheers
Marco

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 825
  • David Merz the Third
    • MerzTheThird
Re: mapping dont match
« Reply #4 on: May 24, 2017, 10:42:38 am »
I have never had much success exporting from NURBs modeling to something which preserves the UVs without taking some sort of extra step to correct the UVs in another editor, such as Blender. It isn't often that it is necessary, but my workflow usually goes.

MoI3D (NURBs) export mesh to OBJ
Import OBJ mesh into Blender, unwrap and correct UVs in Blender
Export new mesh with corrected UVs as OBJ or FBX
Import OBJ/FBX into Keyshot

Not ideal, and usually not perfect. The UV question in regards to NURBs modeling has always been a big challenge for most designers I know.
The true problem is that NURBs surfaces do not take into account 'edge flow' like polygonal modeling would, so when they are converted to a mesh, usually, the 'edges' of a surface has no information built in that says, this trimmed surface CONTINUES onto this coinciding trimmed surface.

Though...if MWO suspects that the Rhino to KS plugin could work, that'd be interesting to me! Any confirmation?




Offline Tak

  • Newbie
  • *
  • Posts: 6
Re: mapping dont match
« Reply #5 on: May 25, 2017, 12:57:10 am »
Marco and DMerzIII, thank you guys for the reply.
Unfortunately I usually use the plugin "Rhino to Keyshot" so that wouldn't be the best solution to this..

Marco , thanks for trying and sharing!
your cylindrical mapping seems working very well! : )
but how do you know the UV coordinates are broken though?
that may give me a hint when I model objects in Rhino.

DMerzlll,
Thanks for sharing your technique! I didn't know that the NURBs modeling occurs this issue, good to know. so I really have to be careful when I model in Rhino huh.
After I read your reply I tried to import STEP file into Keyshot and uncheck "Import NURBS data" but nothing changed..
so I will be careful when I model things in Rhino and when I encounter this issue I will try use "cylindrical."


Additional Question :
when I exploring different mapping type, when I hit specific one (usually "UV Coordinates") sometimes the map image just gone forever.
I can't shift / position anything besides the object and changing scale is not helping at all.
Is it a bug? or is there anyway I can fix this when I encounter this issue??

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 825
  • David Merz the Third
    • MerzTheThird
Re: mapping dont match
« Reply #6 on: May 25, 2017, 10:57:24 am »
In regards to your last additional question, that is odd! I don't see that very often, but it could be a result of a bug? In that case, my first instinct would be to hit the reset button on the mapping tool and see if that gets things back to square.

Unfortunately, not importing the NURBs data won't solve anything, the problem is a little deeper than that. As I mentioned before, the way modeling works with NURBs, the UVs are not seamless, it treats each 'surface' as it's own map, so when two surfaces come together and you see an edge in Rhino, that's where you'll see problems in the UV map. It's just the nature of working in NURBs.

Here's a thread with some more explanation, as you'll see, this is a problem I've been challenged by as well! =)

https://www.keyshot.com/forum/index.php?topic=10828.0

Start on page one if you're going to ready everything, but Martin's writeups starting on Page 2 do the best job of describing the situation.

Happy Reading!


Offline Tak

  • Newbie
  • *
  • Posts: 6
Re: mapping dont match
« Reply #7 on: May 26, 2017, 02:06:23 am »
DmerzIII
I think I tried the reset button when I had this issue but I opened the file again today to try it and the bug didn't show up ( i mean graphic image shows up  : P ) so restarting Keyshot would probably work for this. I will try it again when I encounter this bug.

Oh yeah I briefly saw that thread, the thread looks very handy. I will definitely read them later.
NURBs data and Keyshot realtionship sounds pretty tough..
Fortunately, I have other cleaner model to replace this model so it wouldn't be a much trouble this time but I cannot imagine how nightmare would be when I don't have perfect replacement..
I will look into it and keep following the thread.
but Thanks so much for sharing and helping DMerIII !!! : )

oh, please give me your thoughts on my another thread on this Texture board when you get a chance. haha.

Tak
 
« Last Edit: May 26, 2017, 02:09:13 am by Tak »