Author Topic: Geometry Editor - Object appears too far away  (Read 3281 times)

0 Members and 1 Guest are viewing this topic.

Offline theAVator

  • Full Member
  • ***
  • Posts: 173
  • Acting my shoe size since 1984
Geometry Editor - Object appears too far away
« on: March 31, 2017, 06:21:34 am »
So, not sure if it's bug or anything, I'm guessing it's something I have set incorrectly, but its driving me nuts.

I brought an object into the Geometry editor, but it appears too far away to actually edit. When I zoom in, it gets to a certain point (still too far away to be useful) and then begins slicing through the model - slice too far and the model disappears (kinda like when you're in Ortho mode and zoom in too far). The model itself is in perspective mode, the camera drop down in the geom. editor is set on active camera (but I also tried changing it to perspective with no positive change in results).

Any ideas? I'm sure its just something stupid I'm forgetting about or overlooking. It doesn't happen on all models either, just a few here and there.

Offline Will Gibbons

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2462
  • Training Specialist at Luxion
    • KeyShot Training
Re: Geometry Editor - Object appears too far away
« Reply #1 on: March 31, 2017, 06:46:49 am »
Right-click in the geometry editor and click 'center and fit part' and you should be able to zoom in on it.

Offline theAVator

  • Full Member
  • ***
  • Posts: 173
  • Acting my shoe size since 1984
Re: Geometry Editor - Object appears too far away
« Reply #2 on: March 31, 2017, 10:22:12 am »
I'll give that a try.

I usually do a "Look At" to focus on a part or grouping, but in this case, that didn't produce a favorable result. maybe it's the fitting part that solves the issue?

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1018
Re: Geometry Editor - Object appears too far away
« Reply #3 on: March 31, 2017, 12:39:25 pm »
Right-click in the geometry editor and click 'center and fit part' and you should be able to zoom in on it.

This works every time for me.

Offline theAVator

  • Full Member
  • ***
  • Posts: 173
  • Acting my shoe size since 1984
Re: Geometry Editor - Object appears too far away
« Reply #4 on: May 24, 2017, 09:58:22 am »
So, that worked out great in that instance, and many more since... but now its not working for this instance.

It's like there's that cutting plane out there in space and the part is either far away or cut off. Performing the center and fit essentially steps over that line, and so the screen goes blank and I can't see the part until I zoom back out far enough. looking at the part doesn't produce any change, changing the aspect ratio doesn't produce any results,  switching to ortho doesn't produce any change (didn't think it would anyways), switching back to perspective doesn't produce any results. No matter what I do, in the geometry editor I cannot zoom into the object any more than you see in the attached screenshot.

Any ideas?

Offline DMerz III

  • Hero Member
  • *****
  • Posts: 516
  • David Merz the Third
    • MerzTheThird
Re: Geometry Editor - Object appears too far away
« Reply #5 on: May 24, 2017, 10:33:18 am »
AFAIK, there's no way to edit the 'view cutoff' distance in the geometry editor. However, have you tried toggling between Orthographic Camera and Perspective camera in the editor? You can do so by clicking the 'camera' icon up in the top menu bar within the editor. Maybe this will help?


Offline MWo

  • Hero Member
  • *****
  • Posts: 571
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: Geometry Editor - Object appears too far away
« Reply #6 on: May 25, 2017, 02:41:26 am »
AFAIK, there's no way to edit the 'view cutoff' distance in the geometry editor. However, have you tried toggling between Orthographic Camera and Perspective camera in the editor? You can do so by clicking the 'camera' icon up in the top menu bar within the editor. Maybe this will help?


The look at option in context menus solves the cut view problem. This function defines the centre of rotation and distance (camera to object).


Hope that helps.
Cheers
Marco

Offline spassvogel

  • Hero Member
  • *****
  • Posts: 6289
Re: Geometry Editor - Object appears too far away
« Reply #7 on: May 25, 2017, 06:05:24 am »
There must be another piece of geometry in the scene far away from the object that you are trying to center. Can you check for that?

Offline DMerz III

  • Hero Member
  • *****
  • Posts: 516
  • David Merz the Third
    • MerzTheThird
Re: Geometry Editor - Object appears too far away
« Reply #8 on: May 25, 2017, 11:00:27 am »

The look at option in context menus solves the cut view problem. This function defines the centre of rotation and distance (camera to object).


Hope that helps.
Cheers
Marco

Marco, that is good to know, I have always appreciated that this is automatic! Drives me nuts in some other applications.

Offline theAVator

  • Full Member
  • ***
  • Posts: 173
  • Acting my shoe size since 1984
Re: Geometry Editor - Object appears too far away
« Reply #9 on: May 25, 2017, 03:08:33 pm »
So I can say for sure that there isn't any geometry way out there that its having to deal with - I did have that in the last model and is fairly apparent as a model whose longest piece is around 800 cm, but the model's size lists as something like 8 billion cm you kinda know something's up. However, even in that case - I didn't experience this issue. This seems to be tied to the Geometry editor's camera somehow, and I don't really know how to change any of that. I can go into my scene tree and click on the part and choose Look AT or Center and Fit Part, or do those same things in the normal view window, but as soon as you go in the geometry view/geometry editor, it starts acting funky like this.

The best i can describe it is: take your model and take the longest distance from the model's center that a piece of geometry extends to, then take that distance and make a sphere of that radius. Now, whenever you cross that sphere it starts cutting away the model from view, and the closer you get, the more it cuts away. Now, technically right clicking in the geometry view and selecting Center and Fit works as intended - however you've crossed through that sphere/shield and have cut it from view so the only way to see it is to zoom out until you clear the shield - in which case the part becomes to small/far away to work with. I'll try and do a screen cap tomorrow, but if anyone has any ideas in the meantime...

Offline DMerz III

  • Hero Member
  • *****
  • Posts: 516
  • David Merz the Third
    • MerzTheThird
Re: Geometry Editor - Object appears too far away
« Reply #10 on: May 26, 2017, 07:35:16 am »
I'm going to mention this again because you never said you've tried it from my first post.
If you've tried it and still doesn't help, then I apologize, but give this a try.

Also, how close to the center of the environment is this piece of geometry, in the position tab, if you click center part (not to be confused with center and fit into the camera view) but actually moving the model in space, does that fix this problem?
Could be an issue with the origin of the model based on how it was modeled and imported.


« Last Edit: May 26, 2017, 07:40:11 am by DMerzIII »

Offline theAVator

  • Full Member
  • ***
  • Posts: 173
  • Acting my shoe size since 1984
Re: Geometry Editor - Object appears too far away
« Reply #11 on: May 26, 2017, 10:02:23 am »
@DMerzIII
I guess I had not tried it like that - as mentioned in my semi-original post I had done that through the normal Camera Menu up in the menu bar, which I'm seeing now may not apply to the actual geometry editor. So, I went ahead and did what you suggested in the last post and here is the result: no matter what I select (ortho, persp, active camera) they all cut at the same point or same distance away from the object. So they all still cut, and they all still cat at the same distance from the object. If I do the "center and fit" in each of those camera types, they all act slightly different but in essence it ends up the same distance away and still cuts.

I will try the Centering model thing as mentioned, but before I do, can I get a little clarification on that...
This model is basically a full engineering model of a vehicle (something to the tune of 70,000+ parts), can I select the top model grouping and center that as a whole set of objects, or is it going to go through and center every part and end up with a blob of parts each individually centered?? I just want to make sure before I go ahead and do it... Thx!

Offline DMerz III

  • Hero Member
  • *****
  • Posts: 516
  • David Merz the Third
    • MerzTheThird
Re: Geometry Editor - Object appears too far away
« Reply #12 on: May 30, 2017, 11:16:26 am »
Obviously try it with a temporary 'save as' file haha, I don't want to be responsible for messing up your Keyshot file! HAHA

But in general, YES. If you select the top level model, click center model, it SHOULD center everything as the assembly. A bit hard to confirm that without know how you built/modeled everything though. But again, doesn't hurt to do a little save as and give it a try.

The fact that this is part of a huge assembly, starts to make me think that the scene hierarchy might be erroneous. I'm sorry you're having so many problems with this. I take it whatever you're trying to edit cannot be manipulated in the modeling program? (perhaps this is a provided file)?

Offline theAVator

  • Full Member
  • ***
  • Posts: 173
  • Acting my shoe size since 1984
Re: Geometry Editor - Object appears too far away
« Reply #13 on: June 07, 2017, 06:24:15 am »
Obviously try it with a temporary 'save as' file haha, I don't want to be responsible for messing up your Keyshot file! HAHA
I don't want to be responsible either. hahaha

But in general, YES. If you select the top level model, click center model, it SHOULD center everything as the assembly. A bit hard to confirm that without know how you built/modeled everything though. But again, doesn't hurt to do a little save as and give it a try.
I'll give it a try with a test copy and see. The only thing I fear is that being such a large file, that this will put me out of commission for several hours while it cranks away, but that's more my issue than anything else.

The fact that this is part of a huge assembly, starts to make me think that the scene hierarchy might be erroneous. I'm sorry you're having so many problems with this. I take it whatever you're trying to edit cannot be manipulated in the modeling program? (perhaps this is a provided file)?
It could very well be, this isn't the best example of a vehicle I have worked with - most of the more recent files are modeled a bit nicer and more logically assembled, but as this one is several years old, it's not quite as ideal. Yes, these are modeled by our design engineers and then I go into the database and pull the models out. It tends to be small details that they don't spend the time building out into the model that I have to go through and edit - mostly thing like air valves are one solid piece but may actually be several pieces assembles, valve handles where the rubber coating is a solid piece with the actual metal handle, headlight fixtures that don;t have all the pieces broken out, etc

One thing I've noticed is that it's fairly random, the first day I brought this back I was having so much trouble with one part in particular, and trying other parts made no difference. The a few days later, some parts worked just fine but not others. The next day the one I was having so much trouble with was working much better - not normally or perfectly, but enough that I could do what i needed to. Then another piece wasn't working so well. So, idk, maybe its just a cursed model???

Offline PixelPusher

  • Newbie
  • *
  • Posts: 1
Re: Geometry Editor - Object appears too far away
« Reply #14 on: September 21, 2017, 10:08:21 am »
I had the same issue with my model being clipped while in geometry view. To fix it,  I turned off my "Ground plane" and the camera didn't clip my model anymore well zoomed in. If you have a ground plane in your scene, try turning it off and then enter geometry view.
« Last Edit: September 21, 2017, 10:20:46 am by PixelPusher »