Author Topic: Rhino 5/64 and Keyshot 6 Live Linking Plugin Not Working  (Read 5911 times)

0 Members and 1 Guest are viewing this topic.

Offline MJDesign

  • Newbie
  • *
  • Posts: 15
Rhino 5/64 and Keyshot 6 Live Linking Plugin Not Working
« on: March 28, 2017, 08:47:30 am »
Previous discussion locked.
I downloaded the latest Plugin, and it worked for 1 day, and now has disappeared again. Tried reloading, disabling firewall, etc. still nothing. Anyone else having this issue?

guest84672

  • Guest
Re: Rhino 5/64 and Keyshot 6 Live Linking Plugin Not Working
« Reply #1 on: March 28, 2017, 05:53:26 pm »
Win or Mac?

Offline MJDesign

  • Newbie
  • *
  • Posts: 15
Re: Rhino 5/64 and Keyshot 6 Live Linking Plugin Not Working
« Reply #2 on: March 29, 2017, 05:36:22 am »
Sorry: Windows 10
Keyshot 6/64 bit
Rhino 5/64 bit

guest84672

  • Guest
Re: Rhino 5/64 and Keyshot 6 Live Linking Plugin Not Working
« Reply #3 on: March 29, 2017, 06:08:29 am »
You manage the plugin in  Tools->Options->Plug-ins. It should all be there. You may just need to enable it again.

guest84672

  • Guest
Re: Rhino 5/64 and Keyshot 6 Live Linking Plugin Not Working
« Reply #4 on: March 29, 2017, 06:09:52 am »
Quick question though - how did you install it to begin with? A simple double-click while Rhino is closed is all that is required.

Offline MJDesign

  • Newbie
  • *
  • Posts: 15
Re: Rhino 5/64 and Keyshot 6 Live Linking Plugin Not Working
« Reply #5 on: March 31, 2017, 09:24:28 am »
Quick question though - how did you install it to begin with? A simple double-click while Rhino is closed is all that is required.
Yes, that's how it was installed.
Plugins in Tools is checked, but tab and interface does not appear.

guest84672

  • Guest
Re: Rhino 5/64 and Keyshot 6 Live Linking Plugin Not Working
« Reply #6 on: March 31, 2017, 12:04:49 pm »
Do the commands KeyShot6Render and KeyShot6Export work?

I will need to ask dev about the buttons not showing.

Offline MJDesign

  • Newbie
  • *
  • Posts: 15
Re: Rhino 5/64 and Keyshot 6 Live Linking Plugin Not Working
« Reply #7 on: March 31, 2017, 12:10:26 pm »
Do the commands KeyShot6Render and KeyShot6Export work?

I will need to ask dev about the buttons not showing.

Yup- they work fine, but no buttons show

Offline MJDesign

  • Newbie
  • *
  • Posts: 15
Re: Rhino 5/64 and Keyshot 6 Live Linking Plugin Not Working
« Reply #8 on: March 31, 2017, 12:33:15 pm »
Do the commands KeyShot6Render and KeyShot6Export work?

I will need to ask dev about the buttons not showing.
and LiveLinking not there...

Offline Sean

  • Developer
  • Newbie
  • *****
  • Posts: 8
Re: Rhino 5/64 and Keyshot 6 Live Linking Plugin Not Working
« Reply #9 on: April 03, 2017, 06:37:25 am »
Since the commands work, but the buttons aren't there, is it possible that the toolbar itself was disabled somehow?

1. go to Rhino > Main Menu > Tools > Toolbar Layout. 
2. The Rhino Options window will appear. Under the Toolbars option you will have two Files: default and KeyShot6Plugin. Select KeyShot6Plugin.
3. Enable KeyShot6 inside the Toolbars box/list and click OK.

Alternatively, if the toolbar is enabled here, maybe Rhino has popped it up in some obscure corner of the screen? Disabling and the re-enabling it may force it to appear within the UI.

Finally, Live Linking is still there, but in a fancy new "one-button" approach. Update the scene by re-running the "Render" command. Repeated uses of that command should send the data to the appropriate KeyShot Instance (based on model name).