Author Topic: Render without shadow on background  (Read 7036 times)

0 Members and 1 Guest are viewing this topic.

Offline hdcel

  • Newbie
  • *
  • Posts: 8
Render without shadow on background
« on: March 09, 2017, 09:23:27 am »
Hi

I need to render an image, and only need the ground shadow near the object, and not the shadows outside area.

I have tried to flatten the ground, but not any help.

I use the startup environment.

Offline designgestalt

  • Full Member
  • ***
  • Posts: 160
Re: Render without shadow on background
« Reply #1 on: March 09, 2017, 09:55:45 am »
hi there,
there is a real good video regarding exactly this problem from Esben:


it will also explain why this happens, what you just described and how to handle it...
hope this will help you !
designgestalt

Offline hdcel

  • Newbie
  • *
  • Posts: 8
Re: Render without shadow on background
« Reply #2 on: March 09, 2017, 11:25:41 am »
HI Thx for the video.

Looks good. Except when I add the ground plane the shadow disappear, and I follow everything in the video, and there is no shadow at all.

Offline designgestalt

  • Full Member
  • ***
  • Posts: 160
Re: Render without shadow on background
« Reply #3 on: March 09, 2017, 12:07:34 pm »
hello Hdcel,
are you sure you increased the radius large enough and turned the color to inverse color?
it also might help to darken the color of the unoccluded ...
« Last Edit: March 09, 2017, 12:10:09 pm by designgestalt »

Offline hdcel

  • Newbie
  • *
  • Posts: 8
Re: Render without shadow on background
« Reply #4 on: March 09, 2017, 02:08:32 pm »
Might have been a scale issue. Scaled the fbx down and imported again, and now it seem to work.

I do think the shadow is very rough. Any idea on that.

I have tried some other setting, but not the issue.

The actual preview before I render looks great. When I render as jpg its fine.

PNG, transparent is the issue.

Thoughts?
« Last Edit: March 09, 2017, 02:16:15 pm by hdcel »

Offline designgestalt

  • Full Member
  • ***
  • Posts: 160
Re: Render without shadow on background
« Reply #5 on: March 09, 2017, 03:00:12 pm »
can you tell me about your settings?
I think it is the rendertime from what I see... might be you have to crank it quite a bit up.
what illumination settings are you using... ?
would nee a bit more information to make a proper statement ...
designgestalt

Offline hdcel

  • Newbie
  • *
  • Posts: 8
Re: Render without shadow on background
« Reply #6 on: March 09, 2017, 04:28:36 pm »
Not sure.

Shadow is fine if its a jpg image.

Here is the settings.

Offline designgestalt

  • Full Member
  • ***
  • Posts: 160
Re: Render without shadow on background
« Reply #7 on: March 13, 2017, 02:10:55 am »
sorry for the late reply, I was gone for a few days ...
I think it is the samples...
I assume as jpg is not creating an alpha, you have problems with the opaque shadow.
have you tried Tiff with an alpha yet?
or crank the samples up quite a bit and see what it does to it ...
sure your rendertimes will go up quite a bit as well, but try a section first.
if the rendertimes explode, you might want to try out the second method Esben is suggesting in his video...
hope this helps!
designgestalt

Offline hdcel

  • Newbie
  • *
  • Posts: 8
Re: Render without shadow on background
« Reply #8 on: March 13, 2017, 08:47:56 am »
Tried to set the samples to 128, same results. both on the render and on the ground plane. Still the same result.

This issue is only happening when I use the ground plane.

Same result with Tif.

Offline richardfunnell

  • Sr. Member
  • ****
  • Posts: 371
  • ID Rendering Workflow
    • My page
Re: Render without shadow on background
« Reply #9 on: March 13, 2017, 09:05:36 am »
Strange. What if you increase your shadow quality slider to something like 3 in your render output settings? Also, if you can share a KSP that might help with troubleshooting.

Offline hdcel

  • Newbie
  • *
  • Posts: 8
Re: Render without shadow on background
« Reply #10 on: March 13, 2017, 09:21:06 am »
Set the shadow q to 3. Same result.

Turned off sharp shadow also, same result.

Here is the key shot file, and a test render:
https://dl.dropboxusercontent.com/u/20543207/keyshot/test-shadow.zip


Online Esben Oxholm

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 1642
  • esbenoxholm.dk/keyshot-video-course
    • Freelance CG Artist
Re: Render without shadow on background
« Reply #11 on: March 13, 2017, 11:18:03 am »
Strange thing.
Seem to work fine using 'max samples' here.

Offline richardfunnell

  • Sr. Member
  • ****
  • Posts: 371
  • ID Rendering Workflow
    • My page
Re: Render without shadow on background
« Reply #12 on: March 13, 2017, 11:29:24 am »
Ok, there are two solutions to this, looks like Esben had the same feedback :)

Easier solution: Render with max time or max samples. I reduced the occlusion radius to 0.2 to see a difference. Leaving all your other settings as-is, I rendered it to 256 samples and the artifacts are gone.

More complicated solution:
If you use Advanced Control, you have to crank a lot of your settings up and make some changes to get good results, and then I don't think the results are good. For example: I also increased the material samples for the Ground material (hidden under roughness) to 32, as well as samples in the occlusion texture.
In order to get rid of the strange artifacts, I changed the follow sliders in your render output settings:
Samples: 64
Antialiasing: 8
Shadows 5
It seems like this was the minimum needed to get good results, which is much higher than I usually render with.

Offline hdcel

  • Newbie
  • *
  • Posts: 8
Re: Render without shadow on background
« Reply #13 on: March 13, 2017, 11:42:58 am »
awesome.

That helped a lot.

I guess it react very different when you use the added geometry plane.

Thx again.

Offline designgestalt

  • Full Member
  • ***
  • Posts: 160
Re: Render without shadow on background
« Reply #14 on: March 13, 2017, 01:39:02 pm »
ok, here is a funny one:
 I don't have that problem with that file on my machine, no matter what settings I use. even with just very few samples, the shadow does probably not have the resolution, but it does not show the artifacts!
however I had the exact same problem a couple of weeks ago with these goggles here:
https://www.keyshot.com/forum/index.php?topic=14156.msg71622#msg71622
I cranked up the samples and adjusted the settings but the problem was, as there is transparency in the glasses (and with the color changing glasses I used a curvature gradient) the rendertimes absolutely exploded.
I tried a bunch of different things, but cranking up the samples seemed to have the highest effect!
if you look very closely you can still see the artifacts underneath the belt, although I tweaked it in photoshop.
I changed the PC in the meantime and after reading this topic as well as all your answers today, I downloaded hdcel´s file to check and could not generate the problem!
so I reopened my files again from a few weeks back, and I also could not provoke the error!?!
take a look at the screengrab (at 50 samples), the shadow is missing resolution, but is not showing artifacts! (it used to be big chunky blocks!)
a miracle ?
the new machine?
any ideas?
I assume it might be a bug ?

regards
designgestalt


« Last Edit: March 13, 2017, 01:43:21 pm by designgestalt »