Author Topic: tessellated looking geometry  (Read 1682 times)

0 Members and 1 Guest are viewing this topic.

Offline Shaun B

  • Newbie
  • *
  • Posts: 6
tessellated looking geometry
« on: February 20, 2017, 08:58:42 pm »
Can someone help please by trying to pin point the issues with these surfaces?
Ive imported geometry files a couple of times now and changed the tessellation quality to 0.30 rather than the keyshot standard 0.20

The weird things is the kitchen cupboards is an FBX file, and the roof over hang is a solidworks file.
I cant see any other parts effected like these, which is weird.

Thoughts?


Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 810
  • David Merz the Third
    • MerzTheThird
Re: tessellated looking geometry
« Reply #1 on: February 22, 2017, 02:41:09 pm »
At first glance, it seems like it could be 'z-fighting' or two surfaces occupying the same exact space.
If that's not it, then it could be the normals are a bit wonky? Try recalculating normals in the geometry editor.

That's where I'd start

Offline Shaun B

  • Newbie
  • *
  • Posts: 6
Re: tessellated looking geometry
« Reply #2 on: February 22, 2017, 06:59:04 pm »
Cool, thanks dmerziii,
That's what I thought too at first (z fighting), but have checked the geometry a few times (again just now to ensure I didnt miss anything) any its look OK.

Thanks for suggesting normals editor. Ive never used it, but just had a quick look at it in Geometry editor...
Ill just have to have a Play with it, and work out how the this feature functions. Im sure its straight forward

Thanks for replying, Ill post if I get a solution.
Cheers
Shaun

Offline DMerz III

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 810
  • David Merz the Third
    • MerzTheThird
Re: tessellated looking geometry
« Reply #3 on: February 23, 2017, 01:17:22 pm »
No problem, I hope you do figure it out. The geometry editor is a bit limited at the moment, but what you'll want to do is select that piece of geometry and select 'Edit Normals'. If you turn on the checkbox that says 'Show Face Normals' (i think) you'll see the little hairs come off the surfaces which should all generally be pointing the same way, if they are not, then you know you've got a problem!

You can try clicking 'calculate normals' and sometimes that will fix slight problems. It's not a perfect solution, but it's just an idea.

The other thing I am thinking of would be to check the texture mapping, if you're using a 'planar' mapping approach, you sometimes don't realize the coordinates are off. Other than that, please let me know if you discover the issue!