Author Topic: Import CREO Assembly with parts with multiple materials on surfaces  (Read 3298 times)

0 Members and 1 Guest are viewing this topic.

Offline 9colai

  • Newbie
  • *
  • Posts: 4
Hi

I'm trying to import a CREO 3.0 assembly file, with multiple materials on part level, into Keyshot, but I'm only able to change the material for the whole parts in the import and not on the surfaces on the parts. I tried with a part file and it works just fine, but it doesn't work with the assembly file.

Do i have to use some special kind of setting when i import the assembly file in order to make it work?

Best regards
Nicolai

guest84672

  • Guest
Re: Import CREO Assembly with parts with multiple materials on surfaces
« Reply #1 on: September 30, 2016, 06:52:51 am »
Are the colors assigned on the part or assembly level?

Offline 9colai

  • Newbie
  • *
  • Posts: 4
Re: Import CREO Assembly with parts with multiple materials on surfaces
« Reply #2 on: October 01, 2016, 10:03:44 am »
Are the colors assigned on the part or assembly level?

I tried both, it doesn't help.

Offline Chad Holton

  • Hero Member
  • *****
  • Posts: 1370
    • Portfolio
Re: Import CREO Assembly with parts with multiple materials on surfaces
« Reply #3 on: October 01, 2016, 11:52:26 am »
Are the surfaces linked in KeyShot?

Also, are you the creo user?

Offline 9colai

  • Newbie
  • *
  • Posts: 4
Re: Import CREO Assembly with parts with multiple materials on surfaces
« Reply #4 on: October 01, 2016, 12:34:42 pm »
Are the surfaces linked in KeyShot?

Also, are you the creo user?

No there is only one feature per part in Keyshot, and yes I'm the CREO user.

Offline Chad Holton

  • Hero Member
  • *****
  • Posts: 1370
    • Portfolio
Re: Import CREO Assembly with parts with multiple materials on surfaces
« Reply #5 on: October 01, 2016, 02:29:03 pm »
Okay, just tested and worked fine for me. When importing, try using "Group by Material" and use "Separate Materials by Part".  Also, the plugin may be worth trying as well: https://www.keyshot.com/downloads/plugins/

Offline 9colai

  • Newbie
  • *
  • Posts: 4
Re: Import CREO Assembly with parts with multiple materials on surfaces
« Reply #6 on: October 02, 2016, 02:47:30 am »
I think it's some kind of bug, because i tried it with another assembly and it was working fine there. But thanks for the help! :-)