Author Topic: Area light shadows switch, no effect?  (Read 2344 times)

0 Members and 1 Guest are viewing this topic.

Offline Armill

  • Newbie
  • *
  • Posts: 25
Area light shadows switch, no effect?
« on: August 07, 2016, 03:05:28 am »
Hello,

In Keyshot Pro 6.2 the "visible in shadows" switch of the area light diffuse settings doesn't make any difference in renderings. The manual says "toggle whether or not the light source geometry casts a shadow in realtime window", but the shadow is always there (see attachment), regardless weather the toggle is switched on or not. Is this a known bug?

Offline richardfunnell

  • Sr. Member
  • ****
  • Posts: 379
  • ID Rendering + KeyShot Workflow
    • My page
Re: Area light shadows switch, no effect?
« Reply #1 on: August 08, 2016, 07:22:24 am »
Hi Armill,

I understand the confusion with that checkbox, but any light that's added to a scene will contribute shadows for other objects.
In your example, the sphere will always cast a shadow because there's a strong light next to it. This cannot be disabled.

In KeyShot, added geometry (even Area Lights) is taken into consideration for the shadow calculations by default.
The "Visible in Shadows" checkbox enables/disables shadows for that individual part. I tend to turn it off in every scenario.
In the attached mockup you can see the cast shadow for that part being disabled.

Offline Armill

  • Newbie
  • *
  • Posts: 25
Re: Area light shadows switch, no effect?
« Reply #2 on: August 08, 2016, 07:51:46 am »
Ohh ok now I understand. :)

I thought this checkbox refers to other geometry, but it refers to itself.

Offline bdesign

  • Hero Member
  • *****
  • Posts: 795
Re: Area light shadows switch, no effect?
« Reply #3 on: August 09, 2016, 05:36:08 am »
Here is a node network for toggling object shadow visibility. Connect a Color To Number node (default settings)>Opacity of an Emissive material (all Advanced options disabled)>Label 1 of your main material (Advanced in this example). Connect the main material>Label 1 of another Emissive material ("Visible to Camera" and "Visible in Shadows" enabled, all others disabled). Toggle object shadow on/off by enabling/disabling "Visible in Shadows" for the upstream Emissive material. The "Visible to Camera" option is enabled so that the object can be selected in the viewport.

Eric