Author Topic: Camera pivot point and coordinate system messes up  (Read 2137 times)

0 Members and 1 Guest are viewing this topic.

Offline Merijn

  • Newbie
  • *
  • Posts: 12
Camera pivot point and coordinate system messes up
« on: April 01, 2016, 03:14:28 am »
Hey all,

I am experiencing a few annoying issues with animating cameras in keyshot 5.3 pro.
I have been encountering this problem quite often when working on semi complex animations.
I am not sure if these two issues are related or not.

The first issue is that the pivot point of the camera seems to jump to a random place, away from the model. This usually happens when I am halfway finished animating the camera. The new pivot point is usually some point way below the ground plane. From that moment on, orbit animations result in the model flying out of view.
My previous workaround for this porblem was importing the whole keyshot project into a new keyshot file. That usually fixed the camera positions.
But I am wondering if this is caused by something I am doing  wrong.
Using the "Look at" function in these situations results in the camera looking at a random position, away from the part that I just selected.

The other issue is the coordinate system following the animated camera. (see screenshots)
The camera inclines and orbits to a top view position. The coordinate system stays in the same position relative to the camera. This not only messes up the global axis directions, but when I switch to the Free Camera (screenshot), the whole scene (see shadows) is tilted.

Hoping you can help, because I am unable to finish my work this way.

Kind regards,

Merijn