Author Topic: KS Not Using Names on SolidWorks Part Import  (Read 3990 times)

0 Members and 1 Guest are viewing this topic.

Offline Robb63

  • Hero Member
  • *****
  • Posts: 584
KS Not Using Names on SolidWorks Part Import
« on: April 22, 2015, 05:36:22 am »
Like a lot of product designers, I build most of my SolidWorks models as a single part file with multiple bodies in the same part file. I name the solid bodies in the tree (see attached), but when I import the part (using either the plugin, or a true import), the names are ignored, and I have a huge list of parts in KS with essentially the same name.

If I take the same file, and tell it in SW to save out as an assembly I can bring in the assembly with the part names intact. The problem with that is, SW doesn't remember any surfaces in this new assembly that I have made a different color in order to be able to assign them a different material in KS. In addition the save to assembly in SW doesn't allow non-solid parts to be part of that exported assembly.

Any ideas, or workarounds?

Offline Speedster

  • Hero Member
  • *****
  • Posts: 2625
Re: KS Not Using Names on SolidWorks Part Import
« Reply #1 on: April 22, 2015, 05:46:47 am »
Do you name the bodies in the body dropdown, or in the Feature Manager tree?  I always rename the feature that creates the body down in the tree, which then shows up properly named in the body dropdown, but also shows up correctly in the KeyShot tree.
Bill G

Offline Robb63

  • Hero Member
  • *****
  • Posts: 584
Re: KS Not Using Names on SolidWorks Part Import
« Reply #2 on: April 22, 2015, 06:02:11 am »
Hi Bill,
I have been renaming the parts inside the "Solid Bodies Folder" in the tree hoping that would work.
Just tried naming the original feature that created one of the parts as you suggested, and even the last feature (usually a fillet) that was applied to a part. Neither one seems to work unfortunately.

I am using the educational version of SW (not sure if that is the issue?). I'm teaching, and was hoping to show my students a fix for their models that they are rendering here the end of the semester.
The educational version is a full version, with a watermark if you open the file in a non-edu license.

guest84672

  • Guest
Re: KS Not Using Names on SolidWorks Part Import
« Reply #3 on: April 22, 2015, 10:34:14 pm »
Just spoke to development (sitting right next to all the developers this week). We don't preserve the names of the bodies but will investigate why not.