Author Topic: Labels appear on both sides of material when using Planar mapping  (Read 7878 times)

0 Members and 1 Guest are viewing this topic.

Offline tfboy

  • Newbie
  • *
  • Posts: 16
Is this normal?

I'd normally use projection, but as I want to fine-tune and control exact placement, it's easier to use the Planar mapping and define offsets from axis.

In projection mapping, it's fine.

But when using Planar (z axis in my case), the label appears on the rear of the surface, mirrored, as if it went all the way through the material and stopped at the end.

Offline Esben Oxholm

  • KeyShot Beta
  • Hero Member
  • *****
  • Posts: 1670
  • esbenoxholm.dk/keyshot-video-course
    • Freelance CG Artist
Re: Labels appear on both sides of material when using Planar mapping
« Reply #1 on: April 07, 2015, 08:00:00 am »
Hi tfboy.

Try to use the depth slider under your label options to define how far through the material your label should go.

Offline tfboy

  • Newbie
  • *
  • Posts: 16
Re: Labels appear on both sides of material when using Planar mapping
« Reply #2 on: April 07, 2015, 12:29:04 pm »
Thanks for the suggestion, Esben.
Interestingly, when setting to Planar mapping, the depth option is greyed out.

guest84672

  • Guest
Re: Labels appear on both sides of material when using Planar mapping
« Reply #3 on: April 07, 2015, 02:02:53 pm »
Correct - it is only available for Normal Mapping.

If you want to use planar projection but don't the label to go all the way through, you will need to break out the surface from the rest of the model in your modeling software.

Offline tfboy

  • Newbie
  • *
  • Posts: 16
Re: Labels appear on both sides of material when using Planar mapping
« Reply #4 on: April 08, 2015, 07:11:09 am »
Thanks Thomas,

The advantage I noticed with planar mapping is that it's mapped from the model's coordinates so I can define an exact offset from them to place the label exactly where I want.

With projection, you effectively just "slap it on" and whilst you can fine tune where it ends up, you're not sure exactly where it is in relation to the surface it's on.

So is it possible to define a precise / exact position with any of the label mapping options without having it appear on the other side?

guest84672

  • Guest
Re: Labels appear on both sides of material when using Planar mapping
« Reply #5 on: April 08, 2015, 09:29:17 am »
As I said, you would need to break out the surface as a separate material by assigning a different color. Then you can treat it independently, and the label won't project through onto other surfaces.

Offline tfboy

  • Newbie
  • *
  • Posts: 16
Re: Labels appear on both sides of material when using Planar mapping
« Reply #6 on: April 08, 2015, 01:05:03 pm »
Thanks Thomas.
Out of interest, what is the reason for planar mapped labels to go through? I could think of far more cases where you wouldn't than you would, or at least make it an option like double-sided. It's a shame you have to go back and change things in modelling because of this "limitation".