KeyShot Forum

Technical discussions => Rendering => Topic started by: JAKiii on January 08, 2014, 07:58:31 pm

Title: Strange Shadowing
Post by: JAKiii on January 08, 2014, 07:58:31 pm
Hello Keyshot Braintrust,

What's with the strange shadowing on this image? I'm using the same paint material across many surfaces, but some of those surfaces render with this splotchy shadow. Render settings are high. Any ideas...?

Thanks,
Jamie
Title: Re: Strange Shadowing
Post by: KeyShot on January 08, 2014, 08:25:03 pm
is this rendered using the advanced rendering mode? If yes, then you should increase the global illumination quality.
Title: Re: Strange Shadowing
Post by: DriesV on January 09, 2014, 12:54:13 am
I'm also getting pretty bad results with advanced rendering since the final release version of 4.3.

1st image is realtime reder.
2nd image is advanced control render, with GI quality @ 5.
Lighting with a studio HDRI.

Dries
Title: Re: Strange Shadowing
Post by: thomasteger on January 09, 2014, 05:48:49 am
Make sure to turn off "Global Illumination Cache" in the advanced settings of the render menu.
Title: Re: Strange Shadowing
Post by: DriesV on January 09, 2014, 06:15:25 am
Thomas, without cache I'm getting a distinct noise pattern.

Dries
Title: Re: Strange Shadowing
Post by: thomasteger on January 09, 2014, 11:44:09 am
And GI quality is set to 5?
Title: Re: Strange Shadowing
Post by: JAKiii on January 09, 2014, 07:36:20 pm
I solved this by un-checking "Sharp Shadows" in the Advanced Rendering option -
Title: Re: Strange Shadowing
Post by: DriesV on January 10, 2014, 02:20:21 am
I solved this by un-checking "Sharp Shadows" in the Advanced Rendering option -

Thanks for this tip!
The sharp shadows option does indeed seem to introduce artifacts, no matter what other values in advanced settings. At least in my scenes, on my machine...

1st image: GI cache on, sharp shadows on
2nd image: GI cache on, sharp shadows off
3rd image: GI cache off, sharp shadows on
4th image: GI cache off, sharp shadows off
5th image: realtime reference

Render settings used for advanced control renders: 16 samples, 6 ray bounces, anti aliasing @ 1, shadow @ 1, GI @ 1, pixel blur @ 1.5

You can clearly see there are shadow/GI problems in the renders with sharp shadows on.

Dries
Title: Re: Strange Shadowing
Post by: thomasteger on January 10, 2014, 05:05:31 am
What happens if you increase the GI quality with GI Cache off and SS on?
Title: Re: Strange Shadowing
Post by: DriesV on January 10, 2014, 05:23:02 am
Thomas,

Both images with GI cache off, sharp shadows on.
1st image: GI quality @ 3
2nd image: GI quality @ 5

Dries
Title: Re: Strange Shadowing
Post by: DriesV on January 16, 2014, 12:14:40 am
Any update on this, guys?
KeyShot has become totally unusable for me when rendering with advanced control in 4.3 due to these artifacts. Unless I turn off Sharp shadows, which alters the appearance (depth quality) of the image a lot.
Btw, the artifacting only happens with HDR lighting. When HDRI brightness is 0 and physical lights are used, the artifacts are gone.

The problems are especially apparent on scenes with many GI bounces.

Dries
Title: Re: Strange Shadowing
Post by: KeyShot on January 16, 2014, 03:45:00 am
Hi Dries,

We are looking into this. If you can share a model with [email protected] then that would be great.

Thanks,

Henrik
Title: Re: Strange Shadowing
Post by: br3ttj on January 16, 2014, 06:44:15 am
Are you able to increase your import tessellation, whether in the native CAD program or as you import into KeyShot?  Yesterday, we were experiencing very much the same thing with splotchy shadows and highlights.  After double checking and adjusting shadow quality, global illumination render quality, environment size, we ended up reimporting our SolidWorks model with the beta importer at higher tessellation values and now the renderings are cleaner and the splotchiness seems to be gone.

On a related note, we're getting very good SolidWorks import using the Beta import option.  However, when we choose that option, it also brings in most of our surface geometry from our master models as well, even though they're hidden on layers within each part.  It can be a bit tedious going through each of the parts and deleting all the extra surface quilts to set-up a scene.  Worse yet, if we have to re-import part changes we have to do it all over again.

Title: Re: Strange Shadowing
Post by: thomasteger on January 16, 2014, 10:45:15 am
br3ttj - is this still happening with 4.3? And also, why are you not using the plugin with live linking?
Title: Re: Strange Shadowing
Post by: br3ttj on January 17, 2014, 06:16:43 am
Thomas - as for "still happening with 4.3", I'm assuming you were referencing my comment regarding all the hidden surfaces passing through.  Yes, using the "beta" import option for SolidWorks, this still happens.  As for "Live Linking", we had troubles in the past and just hadn't tried it in a while, but we're doing a lot of new KeyShot rendering this week, so will give it another try.
Title: Re: Strange Shadowing
Post by: thomasteger on January 17, 2014, 06:43:04 am
Yes - correct. Hidden surfaces should no longer come through. We will have another look.
Title: Re: Strange Shadowing
Post by: br3ttj on January 19, 2014, 11:18:08 am
Thomas,

I got the SolidWorks plug-in and, yes, it's so much better to push files from SolidWorks than pull them into KeyShot using the "beta" importer!!!  Quilts are better tessellated, don't have cracks in the seams, and hidden surfaces stay hidden!  I still need to play with "live linking".

Thanks!
Title: Re: Strange Shadowing
Post by: thomasteger on January 20, 2014, 06:08:52 am
We actually discovered that an old bug snuck back in with the BETA importer. Will be fixed.
Title: Re: Strange Shadowing
Post by: powder3D on January 21, 2014, 04:18:08 am
Back on topic:
I got the same problem since the version 4.3 as you can see.
I'm working with 4.2 again now which is fine.
MacBook Pro-User
Title: Re: Strange Shadowing
Post by: guest81576 on February 20, 2014, 03:59:47 pm
I am getting the same shadow noise problem on my renders—real time aking looks fine. Why would advanced tab become so problematic and touchy? I seems to make no difference how high I make the settings...

help.
Much appreciated,
Dimitry
Title: Re: Strange Shadowing
Post by: thomasteger on February 20, 2014, 04:06:52 pm
Uncheck the "Global illumination cache" and you won't see these issues. Once unchecked, it will stay unchecked. Make sure to use 4.3.18.