KeyShot Forum

Technical discussions => Textures => Topic started by: frankie_hnrg on January 27, 2018, 06:21:46 am

Title: Can't Import Materials and UV Mapping Textures from Cinema 4D to Keyshot
Post by: frankie_hnrg on January 27, 2018, 06:21:46 am
Hi everyone!

I am quite new to Keyshot and I encountered the first problem with UV Mapping while trying to render plywood (as It has on the side the wood layers and in front a common wood texture). For this reason I decided to try with Cinema 4D that allows you to UV map pretty well. In fact I managed to map (probably not very well) the plywood as I wanted using photoshop and importing the UV.

Problem started when I tried to export the model in Keyshot for the renderings. I downloaded a Keyshot plug-in for C4D that allows you to directly save from C4D to Keyshot .bip format.

When I try to open the file in Keyshot, the object that I modeled and textured appears completly black and says that the texture in missing( I uploaded a picture) and even if I load it again in the Material Graph, changing also Mapping Type, nothing happen and the object keeps being black...

Plus, even objects with the Presets Material from C4D when imported in Keyshot appears white...

Please help me cause I'm loosing my head  :-\

Thank you very much for your attention!
Title: Re: Can't Import Materials and UV Mapping Textures from Cinema 4D to Keyshot
Post by: mattjgerard on January 29, 2018, 05:58:55 am
In keyshot use the geometry editor to recalculate the normals. Then your model won't be black anymore.

Or in Cinema4d, delete the normals tag.

What version of Keyshot are you using? This was a problem  back on KS6 and the older version of the plugin, but now the plugin just ignores the normals and phong tags. So not sure why you are getting this issue.
Title: Re: Can't Import Materials and UV Mapping Textures from Cinema 4D to Keyshot
Post by: INNEO_MWo on January 29, 2018, 09:39:31 am
In keyshot use the geometry editor to recalculate the normals. Then your model won't be black anymore.

Or in Cinema4d, delete the normals tag.

What version of Keyshot are you using? This was a problem  back on KS6 and the older version of the plugin, but now the plugin just ignores the normals and phong tags. So not sure why you are getting this issue.

The screengrabs are from KeyShot 6
Title: Re: Can't Import Materials and UV Mapping Textures from Cinema 4D to Keyshot
Post by: mattjgerard on January 29, 2018, 12:00:38 pm
In keyshot use the geometry editor to recalculate the normals. Then your model won't be black anymore.

Or in Cinema4d, delete the normals tag.

What version of Keyshot are you using? This was a problem  back on KS6 and the older version of the plugin, but now the plugin just ignores the normals and phong tags. So not sure why you are getting this issue.

The screengrabs are from KeyShot 6

Geez. I didn't even notice that!

So yes, recalculating the normals or deleting the normals tags in cinema before exporting works.

As for the UV mapping itself, I'm not well versed on it so much so I'm not much help at all on that front.
Title: Re: Can't Import Materials and UV Mapping Textures from Cinema 4D to Keyshot
Post by: frankie_hnrg on January 30, 2018, 08:20:00 am
In keyshot use the geometry editor to recalculate the normals. Then your model won't be black anymore.

Or in Cinema4d, delete the normals tag.

What version of Keyshot are you using? This was a problem  back on KS6 and the older version of the plugin, but now the plugin just ignores the normals and phong tags. So not sure why you are getting this issue.

Thank you very much indeed mattjgerard you are amazing!!!I did what you suggested and it all worked fine!
Thank you so much!!
Title: Re: Can't Import Materials and UV Mapping Textures from Cinema 4D to Keyshot
Post by: mattjgerard on January 30, 2018, 01:41:15 pm
Trust me I have the battle scars from figuring that out myself. Wasn't fun, but was very satisfying to be able to report to the awesome KS team what was going on, and they did get it tweaked in the KS7 version of the plugin. Now the plugin just ignores the normals tags. I've been using KS7 and the plugin with C4D R19Studio for about 6 months now its pretty awesome. Mograph objects, cloners, symmetry, and sweeps and extrude objects all translate perfectly. There is still a goofy thing where when I export a scene or object from C4D and import into a current KS7 scene, the new object will be scaled down by .3731 or something like that. Not a huge deal, more humorous than anything. Not sure where that number comes from.