KeyShot Forum

Technical discussions => Materials => Topic started by: Trillo on August 10, 2017, 02:59:13 pm

Title: Problem with gemstone (glass) material
Post by: Trillo on August 10, 2017, 02:59:13 pm
Hello, im having issue with gemstone material. when i'm moving camera with my mouse, the object becomes transparent and with color of gemstone, i applied. but when i stop turing it take my mouse away from the model, letting the scene to render, the object loose transparency and becomes almost black. i tried different objects and scenes, changing the world measurements, but nothing help.

please help to solve this problem,
thank you
Title: Re: Problem with gemstone (glass) material
Post by: guest84672 on August 10, 2017, 03:54:41 pm
Please go to the lighting tab and switch to product lighting. This will increase the ray bounces, and also turn on GI.
Title: Re: Problem with gemstone (glass) material
Post by: Trillo on August 10, 2017, 10:44:58 pm
thank you for quick answer, i tried that but it doesn't work even with maximus rays and GI bounces..
Title: Re: Problem with gemstone (glass) material
Post by: Søren on August 11, 2017, 01:09:00 am
Are you using KeyShot 7 or KeyShot 6? In either case, the transparency distance needs to match the size of the object you apply the gem material to. A dark gem is often a sign of too short a transparency distance.

In KeyShot 6, the transparency distance is implicitly specified in scene units. Look at the size of your object (you can find this by selecting the model in the scene tree and look at object properties below the tree). The transparency distance should be on the same order of magnitude.

In KeyShot 7 you need to do the same, except the transparency distance value now carries a unit explicitly. The same principle applies.

Søren
Title: Re: Problem with gemstone (glass) material
Post by: Trillo on August 11, 2017, 10:26:37 am
problem is solved, guys, thank you!