KeyShot Forum

Support => General Support => Topic started by: JAKiii on February 16, 2011, 10:57:48 am

Title: 2.2 Crashes on material adjust
Post by: JAKiii on February 16, 2011, 10:57:48 am
I have this annoyance:  2.2 crashes and takes my files with it.  Occasionally (every 30 minutes) Keyshot will crash when I'm adjusting a material setting.  Then when I open the most recent saved file, all my material assignments will be gone, the entire model will be shaded in the material I was adjusting when it crashed.

What to do?
Title: Re: 2.2 Crashes on material adjust
Post by: PhilippeV8 on February 17, 2011, 12:20:02 am
Same thing here ... sometimes it only crashes when I save AFTER adjusting material.
Yesterday I had a situation where I was still able to acces the menu, but the render screen seemed frozen.  I couldn't rotate the model or zoom.  When I tried to save the file that time -> crash.
Title: Re: 2.2 Crashes on material adjust
Post by: KeyShot on February 21, 2011, 05:01:53 pm
We just made 2.2.42 available. Can you see if this still happens? We have not been able to reproduce the issue on our end.

-- Henrik
Title: Re: 2.2 Crashes on material adjust
Post by: eric on February 25, 2011, 01:48:30 pm
I have crashes on 2.2.42 while selecting parts/assigning materials.
I never had this before.

The realtime screen freezes.

I still can select file on the menu toolbar.
when I try to save it stops at 99%.
Title: Re: 2.2 Crashes on material adjust
Post by: guest84672 on February 25, 2011, 02:54:50 pm
Is this consistently reproducible?

Thomas
Title: Re: 2.2 Crashes on material adjust
Post by: eric on February 25, 2011, 04:34:51 pm
Well I found this problem on two similar files.
These where exported in 3ds format from 3DSMAX to Rhino3d and then exported to Keyshot by the Rhino 3D plug in.
I can say that the crash or freezing occurs repeatedly while doing the same select/add material operations.

Normally we usually do Solidworks files.
Title: Re: 2.2 Crashes on material adjust
Post by: Burkhard on February 26, 2011, 12:13:42 am
Adjusting the same Material twice - as reference for a new Material - force the crash, so I can confirm that this will happen all the time.
Title: Re: 2.2 Crashes on material adjust
Post by: Richman on February 26, 2011, 06:31:17 pm
I had this happen only once in 2.2.3   crashed and messed up saved bip file.  Upon reopening the model was absent, had to start over.  I'm saving my files like a madman now.
Title: Re: 2.2 Crashes on material adjust
Post by: neilr on March 31, 2011, 09:43:01 pm
Mine just started doing this crash while working on materials also. I too am using an imported bip file, I tried something that has seemed to work I immediately did a save as with a new name and it has not (yet) repeated the crash, I am thinking that whatever the inconsistency was it was fixed when Keyshot saved it. Might  just be a fluke too but only time will tell...
Title: Re: 2.2 Crashes on material adjust
Post by: KeyShot on April 01, 2011, 05:42:40 am
If you can share a file with support then we will work on fixing the issue. So far we have not been able to reproduce it on our side.

Thanks,

Henrik
Title: Re: 2.2 Crashes on material adjust
Post by: trey182 on July 07, 2011, 09:10:28 am
I have actually had a similar problem with Keyshot. Keyshot wants to continually stop at 99% of saving and will freeze up. It doesn't matter how long you wait either. From what I've seen, I can leave it overnight trying to save and it will still be at 99% the next day. I have been able to reproduce this pretty frequently too. I have gotten it to happen by rendering out a large rendering and realize while it is rendering that I want to save the Keyshot file. Everything acts cool and doesn't seem to give the computer an issue with RAM or anything and then 99% hits and its lock up that file. The worst part is that chances are the reason why I am saving the file is because I am pleased with the way the materials are rendering out and when it locks up it is back to step one reassigning materials. I have slowly gotten the hang of this glitch and just learned to always save each file before rendering out the shot you want. And just to clear up what version I have... I have had this issue happen with all of the updates including the latest one. Hope this helps solve the problem.