KeyShot Forum

Support => General Support => Topic started by: Tom Junker on October 27, 2016, 04:52:41 am

Title: KeyShot crashes when using "Material Templates" -> "Add Item"
Post by: Tom Junker on October 27, 2016, 04:52:41 am
Hey,

we just got our KeyShot and i was playing around with some stuff and got an nasty bug already. I would like to use the material template system since i usually assign most materials in CREO to my models/parts. However, every time i try "Add Item" the program freezes and shuts down.

I checked https://www.designassist.info/cadsoftwaredirect/Knowledgebase/Article/View/75/0/keyshot-crashing and removed read only. Since all PCs are administrated by our helpdesk, i can't do much, but changed enable_gpu from true to false, but didn't either. Also, Experimental Features are disabled.

Anything i could try before i ask our helpdesk to download and install Visual C++ and .NET?
Title: Re: KeyShot crashes when using "Material Templates" -> "Add Item"
Post by: Chad Holton on October 27, 2016, 06:31:22 am
Hi Tom,

I know you mentioned that you just got KeyShot but can you confirm the version you're using (e.g. 5.1.234)?  You can find this under Help>About.

You can probably enable your GPU again, as this would cause a crash at startup most likely. As for the issue, I tried to recreate with a Creo file but wasn't able to.  See if it happens on one of the stock scenes that come with KeyShot and let us know what you find out.

Chad
Title: Re: KeyShot crashes when using "Material Templates" -> "Add Item"
Post by: Tom Junker on October 27, 2016, 06:53:04 am
Hi Chad,

sorry for not mentioning it. It is 6.2.105

Cheers, Tom
Title: Re: KeyShot crashes when using "Material Templates" -> "Add Item"
Post by: Will Gibbons on October 27, 2016, 07:28:53 am
I just gave it a go and didn't have any issues with crashing. I was able to add, create, delete and use material templates.
Title: Re: KeyShot crashes when using "Material Templates" -> "Add Item"
Post by: Rex on October 27, 2016, 09:33:08 am
I am able to cause a crash by deleting the default entry. Perhaps that is related. I will pass along to development.

Thanks
Title: Re: KeyShot crashes when using "Material Templates" -> "Add Item"
Post by: Tom Junker on October 28, 2016, 12:26:29 am
I am able to cause a crash by deleting the default entry. Perhaps that is related. I will pass along to development.

Thanks

Hey Rex,

thanks for the reply. Now i see the problem. I was trying to add an item into an non existing template. When i add a template and then the item, it is working. Tho, still a bug isn't it?

Cheers, Tom